Release Engineering

Tasklist

FS#30525 - aif (arch installation framework) fails when selecting source

Attached to Project: Release Engineering
Opened by Xi0N (Xi0N) - Tuesday, 03 July 2012, 22:06 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Monday, 26 November 2012, 04:55 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To Dieter Plaetinck (Dieter_be)
Architecture All
Severity High
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
aif (arch installation framework) fails when you select the package source and throws you back to the shell with an error message:
"ERROR: ask_checklist makes only sense if you specify at least 1 thing (tag,item and ON/OFF switch)"

Additional info:
* package version(s) 2011.10.09-2
* config and/or log files etc.


Steps to reproduce:
From a working system and a WM, i.e. KDE, open a terminal and run:
sudo aif -p interactive

Aif starts and when you try to enter the first menu "1 Select Source", aif exits with the message: "ERROR: ask_checklist makes only sense if you specify at least 1 thing (tag,item and ON/OFF switch)"
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Monday, 26 November 2012, 04:55 GMT
Reason for closing:  Deferred
Additional comments about closing:   FS#30528   FS#30525   FS#30512   FS#30465   FS#30239   FS#30126   FS#30045 
 FS#29927   FS#29859   FS#29538   FS#29536   FS#29420   FS#29348   FS#29304   FS#29160 
 FS#29074   FS#29042   FS#28804   FS#28803   FS#28767   FS#28710   FS#28452   FS#28241 
 FS#28096   FS#27785   FS#27783   FS#27592   FS#27583   FS#26771   FS#26645   FS#26260 
 FS#25728   FS#25674   FS#25665   FS#25664   FS#25656   FS#25610   FS#25591   FS#25569 
 FS#24343   FS#24121   FS#24090   FS#23300   FS#22931   FS#22510   FS#22428   FS#22237 
 FS#22088   FS#21505   FS#21231   FS#19936   FS#19454   FS#19448   FS#19279   FS#19229 
 FS#19190   FS#18495   FS#17827   FS#17633   FS#16277   FS#15926   FS#15925   FS#15896 
 FS#15855   FS#15753   FS#15680   FS#15655   FS#15640   FS#14358   FS#14149   FS#13701 
 FS#13632   FS#13425   FS#13105 
Comment by Antonio Hernández (ahdiaz) - Tuesday, 17 July 2012, 16:54 GMT
Hi all,

I had the same issue trying to install from a live CD.
This live CD has been made with archiso, following this guide: https://wiki.archlinux.org/index.php/Archiso

The package versions on this live system are:

* pacman: 4.0.3-3
* aif: 2011.10.09-2

I found out the problem in the function list_possible_repos() on lib-pacman.sh, here: http://projects.archlinux.org/aif.git/tree/src/core/libs/lib-pacman.sh#n65
That grep returns no repos becouse of the "-B 1" argument, so I changed it to look like the grep in the function list_pacman_repos(), on the same file.

The following patch works for me, hope this help you:

---

diff -aur aif/src/core/libs/lib-pacman.sh aif.new/src/core/libs/lib-pacman.sh
--- aif/src/core/libs/lib-pacman.sh 2012-07-15 21:22:37.293264424 +0200
+++ aif.new/src/core/libs/lib-pacman.sh 2012-07-15 22:46:42.642245000 +0200
@@ -64,7 +64,7 @@
# returns all repositories you could possibly use (core, extra, testing, community, ...)
list_possible_repos ()
{
- grep -B 1 'Include = /etc/' /etc/pacman.conf | grep '\[' | sed 's/#*\[\(.*\)\]/\1/'
+ grep '\[.*\]' /etc/pacman.conf | grep -v options | grep -v '^#' | sed 's/\[//g' | sed 's/\]//g'
}

---

Loading...