Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53581 - [thunderbird] Ships with incompatible Lightning add-on and thus Calendar is broken

Attached to Project: Arch Linux
Opened by Konstantin Gizdov (kgizdov) - Wednesday, 05 April 2017, 22:58 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 21 June 2017, 10:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 29
Private No

Details

Description:
Since Thunderbird v38 the Lightning Add-On has been part of the release (https://support.mozilla.org/t5/Calendar/Integration-into-Thunderbird/ta-p/30027) and enable the use of Calendar features in the mail client. The latest version of Thunderbird has been shipped with an incompatible Lightning version - 4.7.6. Shouldn't this have been kept in testing until Mozilla releases a compatible extension? This essentially means the release is broken and now I can't access my calendar at all. This is very frustrating. Why was this released to users?

Additional info:
* package version(s) 52.0-1
* config and/or log files etc.


Steps to reproduce:
# pacman -Syu
start Thunderbird
see "Lightning Add-On incompatible" message
Can no longer use calender features
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 21 June 2017, 10:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Translations for Lightning are missing, but it's another task: FS#53781
Comment by not_realname (not_Martin_Wimpress) - Thursday, 06 April 2017, 05:03 GMT
I can confirm same behaviour. I've also tried all 4 unofficial Lightning beta add-ons that supposedly are compatible with v52 and this is always the resulting error upon opening Thunderbird: "The binary component required for Lightning could not be loaded, likely because the wrong version combination is being used. You currently have Lightning 5.4b4 installed, but should be using a version from the 5.4 series."

I also tried a purging the .thunderbird folder and starting with a fresh profile. There's a complete breakage of Lightning on all the beta versions. I use Lightning everyday as my main calendar app so this is very concerning to me.

What's curious is v52 is not even listed on the Mozilla release page: https://www.mozilla.org/en-US/thunderbird/releases/

This is very odd. Can someone explain this? Was this released in error?
Comment by MvdL (skipper) - Thursday, 06 April 2017, 05:57 GMT
v52 is listed as 52.0b4 - it is a beta version. Even more curious: The "official" Mozilla beta version 52.0b4 works with included lightning, the arch version (v52) complains about not compatible binary version of lightning (52.0b4 vs. 52)...

So, why is lightning on arch package not working?
And why arch package has switched to beta branch?

[edit]
Perhaps because dependency to firefox (which is at v52 in stable branch)?
[/edit]
Comment by J (Holzprozessor) - Thursday, 06 April 2017, 07:04 GMT
This has happened several times now in the past[1]. Arch has released the new stable version of Thunderbird, which hasn't yet been released by Mozilla (they released the source code, but no build yet). It takes a few more days until Mozilla releases the version themselves and thus also releasing the new, compatible version of lightning.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1173888
Comment by Konstantin Gizdov (kgizdov) - Thursday, 06 April 2017, 12:24 GMT
So why isn't this in testing again? If that happens on a regular basis, shouldn't it be part of the release policy for Arch to wait for compatibility? Why do the devs have to break my setup on a whim. Put it in testing and if I want to, I'll update to testing and break my own setup. Isn't that the Arch way anymore?
Comment by Stefan Husmann (stefanhusmann) - Thursday, 06 April 2017, 14:08 GMT
Mistakes happen, therefore we have a bug tracker - so stop whining.
Comment by Konstantin Gizdov (kgizdov) - Thursday, 06 April 2017, 14:24 GMT
That's not whining. I am asking direct questions about Thunderbird's release policy and still have no answer. So yeah, Arch Linux does have a bug tracker - now use it.
Comment by MvdL (skipper) - Thursday, 06 April 2017, 14:57 GMT
calm down - yes, mistakes happens. no, i would not name this complain as whining.

I understood: The release policy has not changed, it simply was a mistake to release this broken v52 version (which will be stable officially very soon).

For me everything is fine with that.
Comment by not_realname (not_Martin_Wimpress) - Thursday, 06 April 2017, 22:51 GMT
How does this have 9 votes and it's still "Unconfirmed"?
Comment by Jelle van der Waa (jelly) - Friday, 07 April 2017, 07:10 GMT
Since we don't all have the time of the world the ticket wasn't assigned yet. Now it is and please keep the discussion on topic.
Comment by Jan Alexander Steffens (heftig) - Friday, 07 April 2017, 07:50 GMT
We do not ship Lightning, hence I did not test for compatibility.
Comment by not_realname (not_Martin_Wimpress) - Friday, 07 April 2017, 07:55 GMT
Isn't Lightning already integrated in TB? Isn't v52 still a beta version?
Comment by Jan Alexander Steffens (heftig) - Friday, 07 April 2017, 08:09 GMT
Not by default (needs a configure flag) and no, it was release code.
Comment by Gert Link (gert99) - Friday, 07 April 2017, 08:24 GMT Comment by Thomas Schuetz (Murray_B) - Friday, 07 April 2017, 11:49 GMT
Well, I had the same problem, the solution would be to activate the compilation of the lightning plugin. There is already a bug report for it: https://bugs.archlinux.org/task/50219
And there is a patch attached, maybe you could look again into it, heftig? Would be really great, because there is no real alternative to lightning.
Comment by Jan-Peter Arndt (ummon) - Friday, 07 April 2017, 18:45 GMT
As far as I understand might integation with the --enable-calendar option be the way to go.
A comment of one of the Developers at the addons.mozilla page from today is as follows:

"Lightning is now distributed with Thunderbird. If you are not getting a compatible version when upgrading to Thunderbird 52, please contact support!"

https://addons.mozilla.org/en-US/thunderbird/addon/lightning/reviews/857710/

This sounds to me as if we might not get lightning as a sepereate add-on anymore.

Best Regards
Comment by Jan Alexander Steffens (heftig) - Friday, 07 April 2017, 19:32 GMT
Unfortunately, doing that leaves the calendar untranslated, as the official language pack XPIs do not contain the needed strings.
Comment by Balló György (City-busz) - Saturday, 08 April 2017, 11:19 GMT
A possible solution is described here:
https://bugs.archlinux.org/task/50219
Comment by loqs (loqs) - Saturday, 08 April 2017, 12:52 GMT
@György Balló that approach seems promising are you going to work on a diff rebased against thunderbird 52?
Comment by Balló György (City-busz) - Saturday, 08 April 2017, 13:17 GMT
@loqs: no, at least I want to get a feedback from heftig before doing that.
Comment by midixinga (midixinga) - Saturday, 08 April 2017, 14:26 GMT
> Unfortunately, doing that leaves the calendar untranslated
untranslated from English? - ok I can live with that - it's better to have an English than no calendar
Comment by B B (0xbb) - Monday, 10 April 2017, 08:49 GMT
I also had to downgrade to Thunderbird 45.8.0 to get Lightning back.
Comment by Thorsten Z (T2k3) - Tuesday, 11 April 2017, 19:11 GMT
See: https://bbs.archlinux.org/viewtopic.php?pid=1702776#p1702776
the workaround is stupid but did the job for me.
Comment by MvdL (skipper) - Tuesday, 11 April 2017, 19:22 GMT
ACK, works for me, too. It is untranslated, but I can live with that.

Loading...