FS#63532 - [hplip] hplip complains there are no ppd files for printer despite them existing. Cannot print.

Attached to Project: Arch Linux
Opened by Lance (Raansu) - Thursday, 22 August 2019, 19:38 GMT
Last edited by freswa (frederik) - Tuesday, 10 March 2020, 21:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No


Trying to add my wireless printer, photosmart C4795, I run into an issue where it's complaining that there are no PPD files for it. But it does exist and it did work in a previous version. I don't remember exact which version that was because it was a while. But I know the PPD file exists. /usr/share/ppd/HP/hp-photosmart_c4700_series.ppd.gz which is what I remember it using last time.

'''[ransu@surface-go-paper ~]$ hp-setup

HP Linux Imaging and Printing System (ver. 3.19.6)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Found device: hp:/net/Photosmart_C4700_series?ip=
error: No PPD found for model photosmart_c4700 using old algorithm.
error: No appropriate print PPD file found for model photosmart_c4700_series

Additional info:
* package version(s): hplip 1:3.19.6-1

Steps to reproduce:
Install hplip and attempt to add a printer.
This task depends upon

Closed by  freswa (frederik)
Tuesday, 10 March 2020, 21:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  hplip 3.20.2
Comment by Allan (4llan) - Wednesday, 28 August 2019, 01:14 GMT Comment by mozzi (Mozzi) - Thursday, 29 August 2019, 15:59 GMT
Same issue with HP Officejet Pro 7940.
Workaround : reinstalled image from a correct install via clonezilla dated July 31st

Here are the working versions from this date

cups : 2.2.11-2
cups-filters : 1.25.1-1
foomatic-db : 3:20190529-1
foomatic-db-gutenprint-ppds : 5.3.1-2
foomatic-db-nonfree : 3:20190529-1
foomatic-db-nonfree-ppds : 3:20190529-1
foomatic-db-ppds : 3:20190529-1
ghostscript : 9.27-1
gutenprint : 5.3.1-2
hplip : 1:3.19.6-1
libcups : 2.2.11-2
Comment by Biró Dávid (fxdave) - Wednesday, 11 September 2019, 19:44 GMT
Same issue with HP DeskJet Ink advantage 3000 series.
Comment by Lance (Raansu) - Wednesday, 16 October 2019, 06:06 GMT
Ok I can make it work if I first install and enable cups on my system BEFORE running hplip. Thing is before the most recent versions I never needed to worry about cups or anything. Not sure what changed.

Install CUPS

sudo pacman -S cups

And enable it
sudo systemctl enable org.cups.cupsd.service
sudo systemctl start org.cups.cupsd.service
Comment by Stefan Förster (HotblackDesiato) - Sunday, 20 October 2019, 11:17 GMT
Same here, the PPDs exit and worked in a previous version. see hp-doctor below. The printer "HP_LaserJet_M1120_MFP_Stefan" is on and connected via USB (shown in lsusb). hplip can't find the printer.


No devices found.


Type: Printer
Device URI: hp:/usb/HP_LaserJet_M1120_MFP?serial=MF36M9H
PPD: /etc/cups/ppd/HP_LaserJet_M1120_MFP_Stefan.ppd
warning: Failed to read /etc/cups/ppd/HP_LaserJet_M1120_MFP_Stefan.ppd ppd file
PPD Description:
Printer status: Drucker HP_LaserJet_M1120_MFP_Stefan ist im Leerlauf. Aktiviert seit Sa 25 Mai 2019 10:43:56 +08
error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_M1120_MFP?serial=MF36M9H
error: Device not found
error: Communication status: Failed

Type: Printer
Device URI: hp:/net/HP_PageWide_Pro_577_MFP?ip=
PPD: /etc/cups/ppd/HP_PageWide_Pro_577_MFP.ppd
warning: Failed to read /etc/cups/ppd/HP_PageWide_Pro_577_MFP.ppd ppd file
PPD Description:
Printer status: Drucker HP_PageWide_Pro_577_MFP ist im Leerlauf. Aktiviert seit Sa 23 Jun 2018 11:52:39 +08
error: Unable to communicate with device (code=12): hp:/net/HP_PageWide_Pro_577_MFP?ip=
error: unable to open channel
error: Communication status: Failed
Comment by Andreas Radke (AndyRTR) - Wednesday, 20 November 2019, 20:47 GMT
I guess the retroarch link is something completely different.

The initial issue seems to be some incompatible ppd file similar to this one: https://bugs.launchpad.net/hplip/+bug/1851203 - you may look for new drivers at

The last bug seems to be something different where a valid ppd is found but no communication is happening. Try removing the printer and readd it. Do you see the same like the other users? But it's probably  FS#64188 .
Comment by Lance (Raansu) - Monday, 25 November 2019, 00:22 GMT

So the included printer drivers are no longer compatible with my printer anymore? If that is true, then how come installing and setting up CUPS allows the included drivers to work again?

It would seem some bug was introduced somewhere that prevents hplip from directly making use of it's included drivers. But CUPS can instead still make use of them.

usr/share/ppd/HP/hp-photosmart_c4700_series.ppd.gz is the included driver file that works for my particular printer the HP Photosmart C4795
Comment by Biró Dávid (fxdave) - Monday, 25 November 2019, 10:19 GMT
For me this was easily fixed by using CLI commands for setting up a printer and manually select the PPD file (there's a directory that contains those). I can't show command lines, because I can't remember. But the problem was, the default PPD file that hplip wanted was not present in the file system, but was present with another name (That's why I had to select it manually).
Comment by Andreas Radke (AndyRTR) - Wednesday, 11 December 2019, 11:38 GMT
One by one:

Lance (Raansu): Initial report here is related to the HP photosmart C4795 - that should work with /usr/share/ppd/HP/hp-photosmart_c4700_series.ppd.gz
Could you manage to setup your printer with recent updates?

mozzi (Mozzi): HP_LaserJet_M1120_MFP - now working with hplip 3.19.11-6 ? If not this should probably be treated in a different bug (look at  FS#64188 )
and look out for upstream bugs first.

Comment by mozzi (Mozzi) - Saturday, 18 January 2020, 18:09 GMT

I think you're wrong : you say "mozzi (Mozzi): HP_LaserJet_M1120_MFP - now working with hplip 3.19.11-6 ?"

I said "same issue with HP Officejet Pro 7740"
Comment by Lance (Raansu) - Tuesday, 10 March 2020, 21:39 GMT
@AnyRTR This appears solved now on hplip version 3.20.2 The GUI no longer throws an error and correctly identifies /usr/share/ppd/HP/hp-photosmart_c4700_series.ppd.gz for my printer HP Photosmart C4795

The bug I reported as is appears solved. I no longer have an issue.