Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58605 - [mesa] 18.0.3-3 freezes kde on window drag between multiple monitors

Attached to Project: Arch Linux
Opened by Heinrich Siebmanns (Harvey) - Tuesday, 15 May 2018, 10:01 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 20 May 2018, 15:13 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Steffens (heftig)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
On new mesa 18.0.3-3 with intel driver dragging windows between multiple monitors freezes the kde desktop completely. Downgrading to extra/mesa 18.0.3-1 fixes the issue with all other packages unchanged (multilib-testing and testing enabled and up-to-date)

Easy to reproduce for me - open a window and drag it between left and right monitor once or twice - freeze. I have to go to the console and restart sddm then.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 20 May 2018, 15:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 18.0.3-4
Comment by Darek (blablo) - Tuesday, 15 May 2018, 11:05 GMT
Probably https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/mesa#n41

BTW Technically more correct

- -D platforms=x11,wayland,drm,surfaceless \
+ -D platforms=x11,drm,surfaceless \
...
- # in wayland
- rm -v fakeinstall/usr/lib/libwayland-egl.so*
- rm -v fakeinstall/usr/lib/pkgconfig/wayland-egl.pc
Comment by Mel (Mel) - Tuesday, 15 May 2018, 14:43 GMT
To add to this:
On mesa 18.0.3-3 with amdgpu dragging window to the top of the screen to trigger maximize and then dragging it down to trigger un-maximize completely freezes KDE.
Downgrading to extra/mesa 18.0.3-1 fixes the issue.
Comment by Jan Steffens (heftig) - Tuesday, 15 May 2018, 16:19 GMT
Yeah, I've had Zoom (from flatpak) freeze after a few seconds of displaying video. Might also be the fault of that experimental patch.
Comment by Darek (blablo) - Tuesday, 15 May 2018, 16:58 GMT Comment by Darek (blablo) - Wednesday, 16 May 2018, 12:28 GMT
"Variant 2" sent again to patchwork
https://patchwork.freedesktop.org/patch/223324/
Comment by Xuanwo (xuanwo) - Thursday, 17 May 2018, 06:11 GMT
> On mesa 18.0.3-3 with amdgpu dragging window to the top of the screen to trigger maximize and then dragging it down to trigger un-maximize completely freezes KDE.

Intel will also be affected, and downgrading to extra/mesa 18.0.3-1 indeed fixes the issue.

BTW, wayland should also be downgraded to 1.14.0-1
Comment by Antonio Rojas (arojas) - Thursday, 17 May 2018, 06:19 GMT
someone moved mesa to [extra] without this being solved, the patch should be reverted ASAP
Comment by Andrei Măceș (amaces) - Thursday, 17 May 2018, 07:48 GMT
Yes, the culprit is in the incomplete fix in https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/mesa&id=937ac0ce615c2307a6d8d02e79b0a7c49bc487ce (for https://bugs.archlinux.org/task/58549). I twice tried to convince them that it's not the proper fix (which is evolving upstream), and 18.0.3-[23] shouldn't leave testing, but they still went ahead. Oh well, 18.0.4 is right around the corner.
Comment by Mel (Mel) - Thursday, 17 May 2018, 08:49 GMT
FWIW extra/mesa 18.0.3-4 seems to be working fine on amdgpu

Loading...