FS#35892 - [libreoffice-common] Text in Calibri font not displaying in LibO 4.0.4

Attached to Project: Arch Linux
Opened by Kenneth Chin (kenchin) - Saturday, 22 June 2013, 16:49 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 01 September 2013, 09:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 21
Private No


I have recently opened a document in LibreOffice Calc and noticed that the document is text-less, but the highlights, borders and images are present. However, I can see the text content at the editbar above when I click on the cells. All the text is in Calibri font. When I change the font to something else, the text content appears correctly.

I then tested Calibri font in LibreOffice Writer and the outcome is the same: Calibri text content does not appear at all. I did a further test on other app like KWrite, however Calibri font can be displayed correctly. Tried disabling embedded bitmap in fontconfig also made no difference.

64-bit system with the following packages installed:
* KDE 4.10.4
* LibreOffice 4.0.4
* freetype2-infinality
* ttf-ms-win8

Steps to reproduce:
* pacman -Syu to update to the latest libreoffice 4.0.4.
* Open a text document or spreadsheet.
* Type something and select the text or cell.
* Change the font to Calibri and the text will disappear, however the text is still present.
* If you the font is changed to some other fonts, like Cambria or Times New Roman etc, the selected text will appear again.

Refer to forum topic for more info:
* https://bbs.archlinux.org/viewtopic.php?id=165528

Additional info:
* In previous versions of libreoffice, this was a non-issue.
* Reverting to freetype2 also gives the same problem.
* Only Calibri font is affected. Other Microsoft fonts are not affected.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 01 September 2013, 09:29 GMT
Reason for closing:  Fixed
Comment by Guillermo Leira (gleira) - Monday, 24 June 2013, 06:53 GMT
I have noticed that previous versions (at least 4.0.3) of libreoffice actually had some kind of problem with calibri fonts. I have been suffering some glitches, like short "hangs": Now and then, the screen got freezed for a few seconds. This only happens if I use calibri.

I have also tested with libreoffice-rpm 4.0.4-2 from aur, and it seems to work fine. At least, I can see all of the calibri text.
Comment by Ernestas (ernetas) - Monday, 24 June 2013, 06:58 GMT
I am also experiencing this bug, but for me all Microsoft fonts are affected and I can see no menus:
I am using ttf-ms-win8. For me, downgrading libreoffice-common solves the problem.
Comment by Dan Andresan (forumache) - Saturday, 13 July 2013, 06:35 GMT
  • Field changed: Percent Complete (100% → 0%)
My request to reopen was denied with the following reason:

LibreOffice has changed the font handling for some reason. If you think something is broken ask upstream and file a bug there!

But if I run the upstream official packages everything works just fine. So upstream will surrely not consider it a bug.

How do I know that the official LibreOffice 4.0.4 works?

- downloaded from libreoffice website the official rpm tar gz
- extracted the tgz
- went into RPMS directory and run: for file in *.rpm; do rpmextract.sh $file; done
- went into opt/libreoffice4.0 and run program/soffice
Opened the same document and surprise, now I see the Calibri letters (Calibri font had to be installed, of course).
Now, quickly, run /usr/bin/soffice, (the Arch built LibreOffice) open the same document and see.... nothing.
So, to resume: the official build works, the Arch build does not.

Again, why is the Arch bug closed and suggested to report to LibreOffice?

Thanks and sorry for re-requesting to be re-open, but it puzzles me as I clearly see it as a Arch specific bug.
Comment by Andreas Radke (AndyRTR) - Saturday, 13 July 2013, 06:38 GMT
All please confirm LibreOffice to fail with only packages from official repos.

I can't make LibO fit for unknown AUR and custom packages. So make sure fontconfig, freetype and ttf-* packages are only from
our official repos.

Then please point me what to fix.
Comment by Nikos Platis (nplatis) - Saturday, 13 July 2013, 07:35 GMT
For me as well, all packages and libraries are Arch official. The Calibri font was installed by hand (Windows 8 version).

Is it possible that, when using the LibO package, some (font rendering?) library is statically linked or brought in with the package, and the version is different than the one used by Arch, thus causing this problem?

Maybe the other bug that I have reported:
is due to the same cause.
Comment by Dan Andresan (forumache) - Saturday, 13 July 2013, 15:14 GMT
For me the bug reproduces having all the packages on the system from the official Arch repositories (core, extra, community). I don't even have AUR configured.
Only the Calibri is manually installed in my .fonts directory. Calibri font works (appear on screen) in gedit or anywhere I ask for it, (including official LibreOffice), but not on Arch built LibreOffice. Tricky...
Comment by Clemmitt Sigler (cmsigler) - Tuesday, 20 August 2013, 17:12 GMT

I just stumbled on this bug report. I hadn't run into this myself, but I checked and I, too, have this problem.

- From Extra, running: libreoffice-common 4.0.4-2 (libreoffice)
- From AUR, running: ttf-vista-fonts 1-6
- HOSTTYPE="x86_64"

The Calibri font doesn't display in a newly created Text Document. I noticed something strange about setting the font to Calibri: When I chose Calibri from the pull-down menu, the text "Calibri" in the pull-down menu didn't appear in its own font, it was printed in a plain-type font. All the other fonts except for Cambria were displayed in their own font. Sure enough, when I tried Cambria as the font, text in a newly created Text Document didn't display, either.

Like others, I'm using fontconfig, freetype and ttf-* packages from official repos except for ttf-vista-fonts and ttf-ms-fonts from AUR. Calibri and Cambria are both provided by ttf-vista-fonts. HTH.

Comment by Aritra Biswas (thorion) - Saturday, 24 August 2013, 23:25 GMT
Bug persists on Arch-built LibreOffice 4.0.5-1.
Comment by Andreas Radke (AndyRTR) - Sunday, 25 August 2013, 09:56 GMT
You need to find out (probably with upstream help) what system lib we build against (my guess) breaks this. You can also do your own 4.1.1 build that is prepared in svn trunk.
Comment by Ng Oon-Ee (ngoonee) - Friday, 30 August 2013, 01:19 GMT
Fixed in 4.1.1 for me