Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#33710 - [nvidia] cannot build against linux in [testing]

Attached to Project: Arch Linux
Opened by John (graysky) - Monday, 04 February 2013, 18:45 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 05 February 2013, 21:28 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Ionut Biru (wonder)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: Cannot build against linux package in [testing]. Error attached.


Additional info:
* package version(s) 313.18-2

Steps to reproduce: Attempt to build pkg against linux-3.7.6-1.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 05 February 2013, 21:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  nvidia 313.18-3
Comment by Andreas (misc) - Monday, 04 February 2013, 18:52 GMT
Getting the same bug (also) with nvidia-beta-all from AUR. Persists after downgrading to 3.7.5.

In fact, I can't even boot properly anymore; system[d] just freezes shortly before it would call the getty. rescue.target still works, though.
Comment by Dave Reisner (falconindy) - Monday, 04 February 2013, 19:04 GMT
Suffers from a similar problem due to the UAPI changes in the kernel.

We may need to provide a compat symlink in /lib/modules/$kernver/build/include/linux to ../generaterd/uapi/linux/version.h

Odd that this didn't occur with 3.7.5, though....
Comment by Philip Müller (philm) - Monday, 04 February 2013, 19:40 GMT
Simple fix:

# fix 3.7.6 build
sed -ie 's|linux/version.h|generated/uapi/linux/version.h|g' conftest.sh
Comment by Dave Reisner (falconindy) - Monday, 04 February 2013, 19:42 GMT
Thanks. That does nothing to fix the actual problem, only cure a single symptom.
Comment by Ionut Biru (wonder) - Monday, 04 February 2013, 20:10 GMT
i wonder if the kernel is bugged. sucks to rebuild again the modules.
Comment by Anke Boersma (abveritas) - Monday, 04 February 2013, 20:23 GMT Comment by John (graysky) - Monday, 04 February 2013, 21:03 GMT
Thanks Anke. I can confirm the patch allows building and produces a functional module.
Comment by Gustavo Alvarez (sl1pkn07) - Monday, 04 February 2013, 21:06 GMT
ok, with @abveritas patch and @philm with little correction, (is "-i" instead "-ie", "-ie" creates conftest.she)

works for me
Comment by Ike Devolder (BlackEagle) - Monday, 04 February 2013, 21:28 GMT
well another fix is:
cd /usr/lib/modules/3.7.6-1-ARCH/build/include/linux/
ln -s ../../usr/include/linux/version.h

but it is indeed a strange problem:
it does 'not yet' happen with the 3.8 series
and it started from 3.7.6
Comment by Vladimir (_v_l) - Tuesday, 05 February 2013, 11:09 GMT
Updating nvidia package, 313-18-2 -> 313-18-3 seems fix the problem, my notebook booted and works fine.
Comment by Dave Reisner (falconindy) - Tuesday, 05 February 2013, 11:10 GMT
Please stop posting unrelated garbage on this bug report. This is about _building_ the nvidia module against the kernel in testing. That's it.

Loading...