Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#31910 - [gnome] PrintScreen key doesn't work anymore

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Friday, 12 October 2012, 05:59 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 13 October 2012, 08:22 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 59
Private No

Details

Description: It is a weird bug. I can only see it on my desktop computer - my laptop one is ok. I reinstalled from scratch one week ago an archlinux with testing repository enabled.

When I try to use PrintScreen in Gnome 3.4 to do a screenshot, nothing happens. No flash, no sound, no screenshot saved.

When I launch gnome-screenshot from command line, it works. It is not a keyboard issue, switching keyboard doesn't fix the problem. Pure systemd based if it is important to add.

Gnome was added using : pacman -S gnome gnome-extra gnome-utils

As I'm using a nvidia GT 210 graphic card, I tried both nouveau and nvidia driver. Nothing changed.

Tried to bind another shortcut to launch gnome-screenshot : no more luck. Tried to create another bind with PrintScreen : nothing.

Logs seems to be completely unuseful : not a single error message. Any ideas ?

Additional info:
xorg-server : 1.13.0-2
gnome-screenshot : 3.4.1-1

Steps to reproduce: just have a fully archlinux with a fully installed gnome with testing repository enabled
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 13 October 2012, 08:22 GMT
Reason for closing:  Won't fix
Comment by Andreas Radke (AndyRTR) - Friday, 12 October 2012, 14:09 GMT
From what I see on the Arch general mailing list keymapping does work with KDE and testing. I assume this to be a Gnome issue.
Comment by Frederic Bezies (fredbezies) - Saturday, 13 October 2012, 07:18 GMT
Good guess. I tried - a weird idea - to upgrade to gnome-unstable, and PrintScreen key is working again ! Looks like something with last xorg-server in testing is "busting" keyboard with gnome 3.4.

Sorry for the not "technical" speech, but I tried to use human language.

Loading...