Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1224 - wireless lan drivers in install disk

Attached to Project: Arch Linux
Opened by Lukas Sabota (punkrockguy318) - Wednesday, 04 August 2004, 22:33 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 03 October 2007, 20:39 GMT
Task Type Feature Request
Category Installation
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the .7 installation disks, some wlan drivers should be included. Here are some packages that should be included:
wlan-ng26 from extra
atmelwlandrivers from punkrockguy318
at76c503a-cvs26 from punkrockguy318
You can not do a FTP install with a wireless card, but with these packages included, you should be able too
This task depends upon

This task blocks these from closing
 FS#7410 - Post Duke Installation ISO bugs and feature requests 
Closed by  Tobias Powalowski (tpowa)
Wednesday, 03 October 2007, 20:39 GMT
Reason for closing:  Fixed
Comment by LB06 (LB06) - Saturday, 16 October 2004, 20:41 GMT
What about ipw2100 and ipw2200? For Intel 2100B and Intel 2200BG, respectively.
Comment by . (Fox) - Saturday, 23 October 2004, 18:11 GMT
I think this is a good idea.
Comment by Aaron Griffin (phrakture) - Wednesday, 27 October 2004, 17:21 GMT
this should also include ndiswrapper and perhaps a utility to request a driver disk (ndiswrapper loads windows networking drivers).
madwifi should also be included.
Comment by Lukas Sabota (punkrockguy318) - Thursday, 25 November 2004, 16:58 GMT
I really hope to see these features in .7
Comment by Aaron Griffin (phrakture) - Friday, 21 January 2005, 17:11 GMT
there's a whole mess of other drivers... madwifi, ummm the atheros ones...
Comment by James Rayner (iphitus) - Saturday, 05 March 2005, 23:53 GMT
and the prism ones too.
Comment by joseph (josephmc) - Friday, 10 June 2005, 03:53 GMT
I have a prism54 that needs firmware but I'm not sure they can include them on the CD w/o some people getting upset.
Comment by arjan timmerman (blaasvis) - Friday, 20 January 2006, 13:29 GMT
status?
Comment by Jeff Mickey (codemac) - Saturday, 08 April 2006, 08:30 GMT
*bump*
Comment by Tom Killian (tomk) - Thursday, 25 May 2006, 08:36 GMT
And bump again - maybe for 0.8, as this didn't get into 0.7.2. :(
Comment by Dave (malagant) - Thursday, 28 September 2006, 19:14 GMT
Bump again...

ipw2200 & rt2500 in ALL install disks
ESPECIALLY net! ;-)
Comment by James Rayner (iphitus) - Saturday, 23 December 2006, 03:13 GMT
the following drivers and their respective deps:
ipw3945
wlan-ng26
rt2500
zd1211
madwifi
rt2x00-cvs
ndiswrapper
at76c503a-cvs
tiacx

and the following tools/fw for some drivers:
ipw2100-fw
ipw2200-fw
wpa_supplicant
wireless_tools

I realise some are cvs, but they're also working drivers. I use the rt2x00-cvs on a daily basis.
Comment by James Rayner (iphitus) - Saturday, 13 January 2007, 09:38 GMT
OK, did a review of the drivers.

Driver Summary:
Safe to include as all GPL:
wlan-ng26, bcm43xx, ndiswrapper, zd1211, rt2x00-cvs, rt2500, madwifi

In question, GPL, but encumbered firmware:
tiacx, at76c503a, ipw2100, ipw2200, ipw3945, rt2x00-cvs*,

rt2x00-cvs(*): safe to include but 2/6 drivers are non functional without firmware.
ipw3945: not sure about that one, but think it's OK.
ipw2x00: according to the faq, we could get away with a license agreement screen.
tiacx: no details, presumably unsafe.
at76c503a: license seemed unclear.

Extra software required:
Just wpa_supplicant, wireless_tools, and the drivers' respective dependencies.

Individual Details:
Where licenses arent quoted, they were found in the source.

ipw3945 - Intel PRO/Wireless 3945ABG
Package: ipw3945
Depends: ipw3945d, ipw3945-ucode\
License: GPL/http://bughost.org/ipw3945/LICENSE
"Redistributions must reproduce the above copyright notice and the
following disclaimer in the documentation and/or other materials
provided with the distribution."
Status: Unsure. Possibly OK.

wlan-ng26 -
Depends: wlan-ng26-utils
License: MPL/GPL (dual)
GPL, so safe.

ipw2100 - Intel PRO/Wireless 2100B
Package: kernel26
Depends: ipw2100-fw
License: Driver is free, firmware is encumbered.
http://ipw2100.sourceforge.net/firmware_faq.php
According to the above, we are free to distribute, so long as
a) License is included (already done)
b) We notify the user that they must agree to the license before using.

Possible solution: Install the firmware elsewhere on the CD, but have a script show license to user before installing it to the firmware dir.

ipw2200 - Intel PRO/Wireless 2200BG/2915ABG
Package: kernel26
Depends: ipw2200-fw
License: Same as ipw2100.

rt2500: Ralink 2500
Package: rt2500
License: GPL
Status: GPL, safe.

rt2x00: Ralink 2x00 wireless chipsets.
Package: rt2x00-cvs
License: GPL/?
rt2x00-cvs contains: rt2500pci, rt2400pci, rt2500usb, rt61pci, rt73usb
rt61pci and rt73usb require firmware, this is not included in any arch packages and is available here:
http://www.ralinktech.com/ralink/Home/Support/Linux.html
No distribution information is given on this firmware.
Status: GPL, Safe, without firmware, but 2 drivers left non functional.

zd1211: ZyDAS ZD1211 802.11b/g USB WLAN
Package: zd1211
License: GPL
Status: GPL, safe.

ndiswrapper: Windows NDIS implementation
Package: ndiswrapper
Depends: ndiswrapper-utils
License: GPL
Status: GPL, safe, but user must provide own windows driver.

bcm43xx: Broadcom 43xx wireless chipsets..
Package: kernel26
Depends: bcm43xx-fwcutter
License: GPL
Status: GPL, safe, but user must cut their own firmware with the tool.

at76c503a: Atmel AT76C503A Media Access Controller
Package: at76c503a-cvs
Depends: at76c503a-fw-cvs
License: GPL/custom
Status: Driver safe (GPL), firmware unsure.

tiacx1xx: TI ACX Wireless chipset
Package: tiacx
Depends: tiacx-firmware
License: GPL/?
Status: Probably safe (GPL). Currently im -mm, but hasnt been merged due to concerns over how it was reverse-engineered. firmware license unsure.

madwifi: Atheros Wireless chipsets
Package: madwifi
Depends: madwifi-utils
License: GPL
Status: GPL, safe.

Comment by James Rayner (iphitus) - Saturday, 13 January 2007, 12:01 GMT
Programs required: wpa_supplicant and wireless_tools, both in [current]
Comment by Tobias Powalowski (tpowa) - Saturday, 31 March 2007, 06:40 GMT
partially implemented by addons directory on iso download
Comment by Andreas Radke (AndyRTR) - Tuesday, 03 April 2007, 11:05 GMT
lowered serverity/priority
Comment by James Rayner (iphitus) - Wednesday, 04 April 2007, 21:48 GMT
Um, what *did* you include tpowa?

I've heard reports that ndiswrapper and bcm43xx-fwcutter were not include. I *clearly* marked those two as safe above.
Comment by Tobias Powalowski (tpowa) - Friday, 06 April 2007, 07:21 GMT
bcm cutter is imho included, but ndiswrapper is broken due to a hidden perl depend.
also think of this, if you include it on install media it needs to be supported to install too.
atm there is no module on the CD to install.
Comment by Derek Carlson (desertViking) - Thursday, 07 June 2007, 17:06 GMT
Including ndiswrapper on the CD does not necessarily imply that you must support it with the installer. I assume you mean that the installer would have to allow the user to launch and configure ndiswrapper. Users who want to use ndiswrapper can run it after the install. Just having it aboard and loaded to the hard drive would be a tremendious benefit.
Comment by Lukas Sabota (punkrockguy318) - Thursday, 07 June 2007, 20:12 GMT
Right. The drivers don't even need to be "supported" by the installer. Just having the packages available for installation on the disk would be very convenient, especially if your only access to the internet is wireless.
Comment by Tobias Powalowski (tpowa) - Wednesday, 03 October 2007, 20:39 GMT
you can download i686 Isos here:
http://www.archlinux.org/~tpowa/rc-iso/686
you can download x86_64 Isos here:
http://www.archlinux.org/~tpowa/rc-iso/x86_64

Loading...