Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#9546 - wlan-ng and latest kernel -> system freeze

Attached to Project: Arch Linux
Opened by Severin (gripir) - Tuesday, 12 February 2008, 15:34 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 17 February 2008, 19:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Tom Killian (tomk)
Architecture i686
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
System freezes during boot-up after loading the prism2_usb modules.

Additional info:
* latest wlan-ng version

here you can see the log output:

prism2usb_init: prism2_usb.o: 0.2.9 Loaded
prism2usb_init: dev_info is: prism2_usb
------------[ cut here ]------------
kernel BUG at net/core/dev.c:852!
invalid opcode: 0000 [#1] PREEMPT SMP
Modules linked in: prism2_usb p80211 sg amd64_agp agpgart shpchp pci_hotplug evdev thermal processor fan button battery ac ext2 mbcache raid10 raid456 async_xor async_memcpy async_tx xor
Pid: 2628, comm: modprobe Not tainted (2.6.24-ARCH #1)
EIP: 0060:[<c02e4776>] EFLAGS: 00010246 CPU: 0
EIP is at dev_alloc_name+0x36/0x40
EAX: 00000000 EBX: df9b3000 ECX: 00000000 EDX: f899eda7
ESI: df9b3000 EDI: df9c1650 EBP: df8ede00 ESP: df9d9d94
DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process modprobe (pid: 2628, ti=df9d8000 task=dfa3e550 task.ti=df9d8000)
Stack: df9b3000 c013eb7a 00000001 c02ef3ce df9b3000 f7fac400 df9c1650 f899e0a2
df9c0000 df93ec00 df9c1650 f89eabe6 f884e6fb f89f1e1c f884e267 f7fac400
df93ec5c f89f1e1c df8ede00 f89f0ca0 df93ec00 f884f4a9 00000000 df8ede1c
Call Trace:
[<c013eb7a>] queue_work+0x5a/0x70
[<c02ef3ce>] linkwatch_schedule_work+0x3e/0x90
[<f899e0a2>] register_wlandev+0x22/0xd0 [p80211]
[<f89eabe6>] prism2sta_probe_usb+0x1d6/0x290 [prism2_usb]
[<f884e6fb>] usb_autopm_do_device+0x7b/0x100 [usbcore]
[<f884e267>] usb_match_one_id+0x27/0xb0 [usbcore]
[<f884f4a9>] usb_probe_interface+0xb9/0x140 [usbcore]
[<c02aab18>] driver_probe_device+0x88/0x190
[<c036b5af>] klist_next+0x5f/0xc0
[<c02aad70>] __driver_attach+0x80/0x90
[<c02a9efa>] bus_for_each_dev+0x3a/0x60
[<c02aa986>] driver_attach+0x16/0x20
[<c02aacf0>] __driver_attach+0x0/0x90
[<c02aa29a>] bus_add_driver+0x8a/0x1e0
[<f884eff5>] usb_register_driver+0x95/0x110 [usbcore]
[<c012e78b>] printk+0x1b/0x20
[<c0152326>] sys_init_module+0x126/0x19d0
[<c0242c9f>] prio_tree_insert+0x1f/0x240
[<c01054e2>] sysenter_past_esp+0x6b/0xa1
=======================
Code: 02 00 00 85 c0 74 24 89 e1 e8 17 e5 ff ff 85 c0 89 c3 78 0e b9 10 00 00 00 89 e2 89 f0 e8 d3 04 f6 ff 83 c4 10 89 d8 5b 5e 5f c3 <0f> 0b eb fe 8d b6 00 00 00 00 53 89 c3 80 38 00 75 08 5b 31 c0
EIP: [<c02e4776>] dev_alloc_name+0x36/0x40 SS:ESP 0068:df9d9d94
---[ end trace bc3036566b280596 ]---


The freeze is caused by wlan-ng. There is a modified driver version created by ZaB|SHC|
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 17 February 2008, 19:04 GMT
Reason for closing:  Fixed
Comment by Severin (gripir) - Tuesday, 12 February 2008, 15:37 GMT
Links to the modified driver:
http://rafb.net/p/WQGed755.html
http://lists.linux-wlan.com/pipermail/linux-wlan-devel/2008-January/003739.html

the attached file contains the modified wlan-ng package.

Loading...