Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8976 - The system freezes by an error caused by intel xorg driver

Attached to Project: Arch Linux
Opened by Alexandre Garcia (alexmgarcia) - Thursday, 20 December 2007, 00:13 GMT
Last edited by Greg (dolby) - Wednesday, 14 May 2008, 17:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity Critical
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: Sometimes my screen becomes blank and hiting ctrl+alt+f1 to go to a tty is impossible.
I checked the logs and found that:

(/var/log/Xorg.log):
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): PRB0_HEAD (0xbc814464) and PRB0_TAIL (0x000145b8) indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.

(/var/log/messages.log):
Dec 19 22:57:51 laptop gdm-binary[7001]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Dec 19 22:57:52 laptop acpid: client connected from 8863[0:0]
Dec 19 22:57:52 laptop acpid: 1 client rule loaded
Dec 19 22:58:04 laptop acpid: received event "button/power PWRF 00000080 00000001"
Dec 19 22:58:04 laptop acpid: notifying client 6921[82:82]
Dec 19 22:58:04 laptop acpid: notifying client 6945[0:0]
Dec 19 22:58:04 laptop acpid: notifying client 7009[0:0]
Dec 19 22:58:04 laptop acpid: client has disconnected
Dec 19 22:58:04 laptop acpid: notifying client 8863[0:0]
Dec 19 22:58:04 laptop acpid: executing action "/etc/acpi/handler.sh button/power PWRF 00000080 00000001"
Dec 19 22:58:04 laptop logger: PowerButton pressed: PWRF
Dec 19 22:58:04 laptop acpid: action exited with status 0
Dec 19 22:58:04 laptop acpid: completed event "button/power PWRF 00000080 00000001"

(note that I need to press power button to reboot the machine)

It is the 3rd time that happens to me (It starts happening today).
This task depends upon

Closed by  Greg (dolby)
Wednesday, 14 May 2008, 17:21 GMT
Reason for closing:  Upstream
Additional comments about closing:   FS#10394 
Comment by Alexandre Garcia (alexmgarcia) - Thursday, 20 December 2007, 00:18 GMT
By the way:
Name : xf86-video-intel
Version : 2.2.0-1
Build Date : Wed Dec 19 07:58:05 2007 UTC
Build Type : Unknown
Install Date : Wed Dec 19 14:00:21 2007 UTC

Name : kernel26
Version : 2.6.23.12-1
Build Date : Wed Dec 19 09:47:01 2007 UTC
Build Type : Unknown
Install Date : Wed Dec 19 13:58:54 2007 UTC

Perhaps the problem is in the intel driver package. It was installed today, so this can be the cause of the problem.
Comment by Alexandre Garcia (alexmgarcia) - Thursday, 20 December 2007, 00:41 GMT
With this version of the driver I can't run xchat:
amg ~ $ xchat
The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadImplementation (server does not implement operation)'.
(Details: serial 310 error_code 17 request_code 145 minor_code 5)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I downgraded to extra driver (I was using testing driver) and now I can open xchat, so the new driver in testing is bugged.
Comment by Joe Olivas (joeolivas) - Friday, 28 December 2007, 06:56 GMT
I can confirm the error and a downgrade to the extra driver solves the problem. The system does not lock up, but all local video output is blank. I could still reboot the system blindly.

More from the log file:

(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): PRB0_HEAD (0x00001474) and PRB0_TAIL (0x000014a0) indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x1 pgetbl_err: 0x0
ipeir: 0 iphdr: 54300004
LP ring tail: 8 head: 1474 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: 4081 instpm: 0
memmode: 306 instps: 80007826
hwstam: ffff ier: 0 imr: ffff iir: 0
Ring at virtual 0xa7a1d000 head 0x1474 tail 0x8 count 31461
000013f4: 00000000
000013f8: 00000000
000013fc: 00000000
00001400: 00000000
00001404: 00000000
00001408: 00000000
0000140c: 00000000
00001410: 00000000
00001414: 00000000
00001418: 00000000
0000141c: 00000000
00001420: 00000000
00001424: 00000000
00001428: 00000000
0000142c: 00000000
00001430: 00000000
00001434: 00000000
00001438: 00000000
0000143c: 00000000
00001440: 00000000
00001444: 00000000
00001448: 00000000
0000144c: 00000000
00001450: 00000000
00001454: 00000000
00001458: 00000000
0000145c: 00000000
00001460: 00000000
00001464: 00000000
00001468: 00000000
0000146c: 00000000
00001470: 00000000
00001474: 00000000
Ring end
space: 5220 wanted 131064

Fatal server error:
lockup
Comment by Jan de Groot (JGC) - Friday, 28 December 2007, 18:58 GMT
I'm seeing my X server going down now and then also. It's not the driver I think, as I've been running xorg-server with my own version of xf86-video-intel for a long while without problems. The problems started appearing after upgrading to one of the latest Xorg-server packages.
Comment by Alexandre Garcia (alexmgarcia) - Friday, 28 December 2007, 19:06 GMT
JGC, in my case with the stable driver it doesnt go down.
Comment by Hu Jiaqi (struq) - Saturday, 29 December 2007, 12:05 GMT
Same problem to my 865g, both i810 and intel driver.
Not every time though.
Comment by Tianxiang Guo (nacre) - Saturday, 02 February 2008, 03:00 GMT
In intel xorg driver 2.2.0, the default accelerate method changed from XXA to EXA, maybe this is the reason?
Comment by Alexandre Garcia (alexmgarcia) - Monday, 25 February 2008, 21:37 GMT
Updated to xf86-video-intel-2.2.1-1, and still havent crashes, but xchat is impossible to open :(

amg ~ $ xchat
The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadImplementation (server does not implement operation)'.
(Details: serial 310 error_code 17 request_code 145 minor_code 5)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
Comment by Alexandre Garcia (alexmgarcia) - Tuesday, 26 February 2008, 08:50 GMT
The crashes are back. :-(
Please to downgrade the version of extra
Comment by Nicolas Bigaouette (big_gie) - Wednesday, 27 February 2008, 04:08 GMT
I'm having thsi crash around once each evening (I don't use this computer during the day). It is really a pain... :(

I don't know when it started. I tryed v2.2.0 and now I'm trying 2.2.1, but the problem is still there. Maybe, as someone suggested, it is because of another package?

I don't use xchat so I don't know for this app....

I'm attaching my Xorg.0.log
Comment by Alexandre Garcia (alexmgarcia) - Wednesday, 27 February 2008, 07:57 GMT
big_gie, try to compile the xf86-video-intel-2.1.1, it isn't bugged (I've compiled and it is ok)
Comment by bowo (potamota) - Sunday, 02 March 2008, 16:55 GMT
im having this crash too, not every time. but mostly when using firefox...
Comment by bowo (potamota) - Monday, 03 March 2008, 07:21 GMT
alexmgarcia thanks, downgroading to xf86-video-intel-2.1.1 fix this for me, although i have this noise now:

(EE) intel(0): detecting sil164
(EE) intel(0): Unable to read from DVOI2C_E Slave 112.
(EE) intel(0): Unable to read from DVOI2C_E Slave 236.
(EE) intel(0): I830 Vblank Pipe Setup Failed 0
Comment by Alexandre Garcia (alexmgarcia) - Monday, 03 March 2008, 08:06 GMT
Hmm, this doesn't happen to me...

amg ~ $ cat /var/log/Xorg.0.log|grep sil164
Comment by bowo (potamota) - Monday, 03 March 2008, 10:08 GMT
^^ actually using latest xf86-video-intel-2.2.1-1 (extra), with Option "AccelMethod" "XAA" fix this too. have you try it ?
Comment by Alexandre Garcia (alexmgarcia) - Monday, 03 March 2008, 13:56 GMT
No. Are you sure that the system doesn't freezes?
Comment by bowo (potamota) - Tuesday, 04 March 2008, 00:49 GMT
yeah you right it still freeze :(, trying 2.1.99 now..
Comment by Alois Nespor (anespor) - Sunday, 09 March 2008, 13:55 GMT
xf86-video-intel 2.2.1 and kernel 2.6.24 freeze - i use AccelMethod EXA
Comment by Alexandre Garcia (alexmgarcia) - Sunday, 09 March 2008, 14:05 GMT
Alois, use 2.1.1.
I can put here my pkgbuild for this (if you want).
Comment by Alois Nespor (anespor) - Sunday, 09 March 2008, 18:17 GMT
Work now nice,no freeze - after complete reinstall Archlinux (i use actual repo) and xorg-server-1.4.0.90-7 from testing. Driver is 2.2.1.
Comment by Alois Nespor (anespor) - Monday, 10 March 2008, 13:14 GMT
I forgot - also udev 118-4 is from testing.
Comment by Damjan Georgievski (damjan) - Tuesday, 11 March 2008, 20:49 GMT
For me the option:

Option "AccelMethod" "XAA"

solved the problem... I think EXA uses parts of the DRI subsystem but this interaction is buggy.
Comment by Nicolas Bigaouette (big_gie) - Friday, 14 March 2008, 21:21 GMT
Using EXA was buggy for me. It crashed after 1 or 2 minutes with this in my Xorg.0.log:
(WW) intel(0): ESR is 0x00000001
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): PRB0_HEAD (0x282165d0) and PRB0_TAIL (0x00016a98) indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.

With XAA, it did crash also but not that often. I had to go back to 2.1.1 with XAA...
Comment by bowo (potamota) - Monday, 17 March 2008, 15:07 GMT
sadly after last update (2.2.1-2) using xaa the crash is back :(
downgrading until i810 still crash, trying using exa now..
Comment by Jan de Groot (JGC) - Monday, 17 March 2008, 15:13 GMT
Does this also happen with xorg-server-1.4.0.90-8 installed? I can't reproduce this on my G33 with 2.2.1-2 and XAA on xorg-server-1.4.0.90-8. You could try using EXA also with these versions, several bugs have been fixed and performance has improved.
Comment by Li Sun (depp) - Monday, 17 March 2008, 15:35 GMT
so far with newest update the freeze hasn't been reproduced
Comment by bowo (potamota) - Monday, 17 March 2008, 17:27 GMT
now seems EXA is more stable than XAA (freeze mostly when using firefox3).

Chipset: "852GM/855GM"
xorg-server 1.4.0.90-8
xf86-video-intel 2.2.1-2
Comment by Alois Nespor (anespor) - Thursday, 20 March 2008, 12:59 GMT
New (RC) pre-released driver http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-2.2.99.901.tar.bz2 fixed several Xv
relate issues, and with bunch of bug fixes as usual.
Comment by Nicolas Bigaouette (big_gie) - Friday, 28 March 2008, 00:05 GMT
I installed the RC (just changed the version in the PKBBUILD) and using EXA. I dont experience any crash! I changed a bit my xorg.conf so that might have helped to...

lspci:
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

xorg.conf:
Section "Device"
Identifier "Card0"
Driver "intel"
# # Disable 2D acceleration
# Option "NoAccel" "True"
# # Old, should be more stable
# Option "AccelMethod" "XAA"
# New, might be buggy
Option "AccelMethod" "EXA"
# https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/177492
Option "MigrationHeuristic" "greedy"
Option "ExaNoComposite" "false"
EndSection

Note that EXA was really slow until I added the "MigrationHeuristic" "greedy" option. The "ExaNoComposite" "false" option was added as suggestions from the ubuntu's bug report. Everything is running fine now. Using compiz fusion from community too!
Comment by Giorgio Lando (patroclo7) - Monday, 21 April 2008, 04:57 GMT
I have tried all the solutions above, and, while they increase the performance dramatically, they do not solve the issue with xchat mentioned above.

Loading...