Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#8712 - Gnome Power Manager does not set brightness using keyboard switches

Attached to Project: Arch Linux
Opened by Paolo Loberto (mrloba) - Monday, 19 November 2007, 19:18 GMT
Last edited by Roman Kyrylych (Romashka) - Monday, 07 January 2008, 23:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


When i try to change display brightness using keyboard switches it goes to lower value and does not grew up!
If i use the slider on applet it works perfectly!

My hardware is an HP Pavilion dv5000(dv5245ea)

Doing some searches i found this as solution for my problem.

Attached there is the patch used by me.

Additional info:
* gnome-power-manager-2.20.0-1

Steps to reproduce:
Try to change display brightness using keyboard
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Monday, 07 January 2008, 23:01 GMT
Reason for closing:  Fixed
Comment by Allan McRae (Allan) - Monday, 19 November 2007, 21:12 GMT
A workaround is to add "video" to MOD_BLACKLIST in /etc/rc.conf
Comment by Allan McRae (Allan) - Tuesday, 20 November 2007, 06:24 GMT
Part of the patch is already applied in gpm-2.20.1. I have attached an updated patch and PKGBUILD which works nicely on my laptop (Dell Latitude D520).
Comment by Paolo Loberto (mrloba) - Tuesday, 20 November 2007, 09:33 GMT
I know about video module, but if i remove it, my gnome-power-manager stops to control the brightness.
So the only workaround for me is using the attached patch that fix a communication problem between hal 0.9.10 and gnome-power-manager.
I also tried gpm-2.20.1 but without any patch it does not work!!
Comment by Loic Nageleisen (lloeki) - Wednesday, 21 November 2007, 19:00 GMT
I encounter the exact same problem on my asus laptop.

more details:
- removing video module prevents brightness keys from working at all (they stop generating any event whatsoever) so this is NOT a workaround.
- with video module but without g-p-m (either not started or jsut by killing it), brightness keys work exactly as expected.
- with video module and g-p-m, brightness keys work, but brightness is set incorrectly, as described above and in gnome bugzilla.

I will try attached patch and report.
Comment by Loic Nageleisen (lloeki) - Wednesday, 21 November 2007, 19:06 GMT
the attached patch fixed it.
Comment by Allan McRae (Allan) - Sunday, 25 November 2007, 12:47 GMT
I still have the problem that after a while g-p-m changes the brightness back to what is set in its preferences. So changing brightness by keyboard works but for only a minute or so.
Comment by Loic Nageleisen (lloeki) - Monday, 26 November 2007, 08:36 GMT
Allan, I think this last issue is unrelated to the bug above.
Some computers have an AC event occuring in ACPI from time to time (as if the plug had been un-re-plugged), and this may trigger a re-set of related functions, incl. brightness.
Check your ACPI log for such an event.
Comment by Allan McRae (Allan) - Wednesday, 28 November 2007, 13:09 GMT
Confirmed that the problem two posts above is unrelated. Actually the dcdbas module needs loaded for g-p-m to continue obeying brightness changes set on the keyboard of Dell laptops.
Comment by Ionut Biru (wonder) - Friday, 14 December 2007, 19:12 GMT
this patch works but the step is very large. in 3 steps i set the brightness to minim and 3 to maxim. how to i set to make smooth steps?
Comment by Ionut Biru (wonder) - Saturday, 15 December 2007, 09:51 GMT
gpm 2.20.2 is working without a patch
Comment by Paolo Loberto (mrloba) - Tuesday, 18 December 2007, 14:37 GMT
I can confirm!
gpm 2.20.2 works without any patch
Comment by Allan McRae (Allan) - Tuesday, 18 December 2007, 22:08 GMT
gpm 2.20.2 does not work here (Dell Latitude D520)
Comment by Allan McRae (Allan) - Tuesday, 18 December 2007, 22:21 GMT
Damn, instead of installing 2.20.2 I downgraded to 2.20.0. :facepalm: I also confirm this works with 2.20.2.