FS#79468 - [gitlab] recognizes my bug reports as spam

Attached to Project: Arch Linux
Opened by Alberto Salvia Novella (es20490446e) - Thursday, 24 August 2023, 17:28 GMT
Last edited by Buggy McBugFace (bugbot) - Saturday, 25 November 2023, 20:22 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Jelle van der Waa (jelly)
Leonidas Spyropoulos (inglor)
Kristian (klausenbusk)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I was trying to report this issue:


But even after setting up:
- An Arch SSO account
- A password on the Gitlab account
- An SSH key on the Gitlab account

I'm unable to post bug reports, triggering the anti-spam filter:
This task depends upon

Closed by  Buggy McBugFace (bugbot)
Saturday, 25 November 2023, 20:22 GMT
Reason for closing:  Moved
Additional comments about closing:  https://gitlab.archlinux.org/archlinux/p ackaging/packages/gitlab/issues/4
Comment by Toolybird (Toolybird) - Thursday, 24 August 2023, 21:30 GMT Comment by Jelle van der Waa (jelly) - Friday, 25 August 2023, 14:25 GMT
Thanks for reporting, this is not intended to happen. We'll have to debug why your post is determined spam by Gitlab.
Comment by Alberto Salvia Novella (es20490446e) - Friday, 25 August 2023, 14:37 GMT
If it helps, I tried to post this bug report verbatim:

Then I tried pasting only the link, but it also didn't work.
Comment by Alberto Salvia Novella (es20490446e) - Friday, 25 August 2023, 14:42 GMT
Just creating a bug report with the following phrase:

If you have the package already installed in your system, with the same or lower version than the first repo, pacman won't upgrade to the repo package.

Will trigger the spam filter.

But it won't with, for example:

When pacman syncs a package that is present in multiple repositories, it always does from the repo listed first, no matter if the package version is older in that repo.
Comment by Alberto Salvia Novella (es20490446e) - Friday, 25 August 2023, 14:45 GMT
Maybe what triggers the filter is the apostrophe (')