FS#75758 - [python-poetry] Wrong dependency version, python-cleo

Attached to Project: Community Packages
Opened by Stefan Tatschner (rumpelsepp) - Wednesday, 31 August 2022, 11:26 GMT
Last edited by David Runge (dvzrv) - Friday, 02 September 2022, 21:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Caleb Maclennan (alerque)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 19
Private No


python-poetry 1.2 needs cleo 1.0:


Currently poetry is broken:

$ poetry --help
Traceback (most recent call last):
File "/usr/sbin/poetry", line 5, in <module>
from poetry.console.application import main
File "/usr/lib/python3.10/site-packages/poetry/console/application.py", line 13, in <module>
from cleo.events.console_events import COMMAND
ModuleNotFoundError: No module named 'cleo.events'
This task depends upon

Closed by  David Runge (dvzrv)
Friday, 02 September 2022, 21:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with python-poetry 1.2.0-5
Comment by Stefan Tatschner (rumpelsepp) - Wednesday, 31 August 2022, 11:38 GMT Comment by Dylan (acerix) - Thursday, 01 September 2022, 03:30 GMT
For reference; I got it working by installing `python-cleo-git` from AUR and `python-crashtest` 0.3.1-6 from the Archive, I also had to install `python-rapidfuzz` and `python-dulwich`.
Comment by Kevin Morris (kevr) - Thursday, 01 September 2022, 21:55 GMT
I would personally consider `python-poetry 1.2` to be a bit too alpha for official linux distribution repositories, due to the fact that `python-poetry 1.2` depends on `python-cleo 1.0.0a5`, which we do not have (nor should, imo, since it's alpha).

We could revert `python-poetry 1.2` back to `python-poetry 1.1.15` using the following steps:

# Revert 1.2.0-2:
$ git revert a24c0c7a5b33075e689792b84e368e7d4b0311cb

# Revert 1.2.0-1:
$ git revert e15a24cf161e43bc9ece66fa50a72bad559e1019

# <Download PKGBUILD.diff> from this thread
$ git apply PKGBUILD.diff

This versioning would use an `epoch=1` to prioritize the new package version over any previous (including 1.2.0-1, 1.2.0-2). This comes with the pretty nasty side-effect that we would have to keep future package release epochs >= 1, but I'm not sure there's really any other way.
Comment by Kevin Morris (kevr) - Friday, 02 September 2022, 07:00 GMT
Seems this also comes with the issue of `python-poetry-core` used with `python-poetry`, as far as I'm seeing.
Comment by Leonidas Spyropoulos (inglor) - Friday, 02 September 2022, 12:47 GMT Comment by David Runge (dvzrv) - Friday, 02 September 2022, 21:35 GMT
We opted for providing python-cleo 1.0.0a5 instead, as downgrading will eventually introduce even more compatibility issues with the other poetry dependencies (which are partly also used by other projects of course).
All required dependencies have been added, apart from poetry-plugin-export (which has been devendored), because it triggered a bug in python-build (see https://github.com/pypa/build/issues/511).

In the hopes that poetry is now functional for daily use: Please report further issues also upstream and/or help upstream(s) to resolve the issues as to arrive at a more stable state again.