Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74753 - [kodi] [gcc] build failure with gcc-12.1 due to warnings being treated as errors

Attached to Project: Community Packages
Opened by John (graysky) - Sunday, 15 May 2022, 12:11 GMT
Last edited by Morten Linderud (Foxboron) - Sunday, 26 June 2022, 17:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Building kodi-19.5-1 results in errors when using gcc-12.1-1 (did not observe this with gcc-11.2). Is this a function of the Arch default *FLAGS or with the way our toolchain is configured or something in the Kodi code base?

...
cc1plus: all warnings being treated as errors

Whatever the cause, adding the following to the kodi PKGBUILD allows a successful build.

export CFLAGS+=" -Wno-error"
export CXXFLAGS="${CFLAGS}"

I reported this upstream as well: https://github.com/xbmc/xbmc/issues/21376
This task depends upon

Closed by  Morten Linderud (Foxboron)
Sunday, 26 June 2022, 17:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  This can be closed now since lxc 1:5.0.0-4 fixed the issue.
Comment by loqs (loqs) - Sunday, 15 May 2022, 15:15 GMT
If I switch to using the system's flatbuffers i.e. ENABLE_INTERNAL_FLATBUFFERS=OFF and add flatbuffers to depends that also allows the build to succeed.
Edit:
Certainly the warning is a false positive possibly https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105329
Comment by Ike Devolder (BlackEagle) - Monday, 16 May 2022, 10:12 GMT
Thanks for the headsup
Comment by John (graysky) - Friday, 10 June 2022, 11:33 GMT
If you look at the github issue I created (https://github.com/xbmc/xbmc/issues/21376), one of the Kodi devs compiled on Ubuntu with gcc 12.1.0 and could not reproduce this. Something in our toolchain is likely.
Comment by John (graysky) - Friday, 24 June 2022, 23:43 GMT
This can be closed now since lxc 1:5.0.0-4 fixed the issue.

Loading...