FS#73022 - [wireplumber] Firefox and chromium load videos and streams forever. No audio in VLC or games.

Attached to Project: Arch Linux
Opened by Matthew Lambert (Mambert) - Tuesday, 14 December 2021, 16:09 GMT
Last edited by Buggy McBugFace (bugbot) - Saturday, 25 November 2023, 20:22 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


Description: Since updating yesterday, videos on youtube,twitch, and reddit are unable to play. However, I can scrub through them and view the full video is loading, just not playing. Youtube suggests to restart the device. Yesterday, if I restarted it would work upon startup, but if firefox would ever close then it would break again. Today the problem is persistent on startup.

To make sure it is not a Firefox, or network issue, I launched chromium completely vanilla. No cookies, history, plugins, or add-ons. The problem still persisted there.

Games can be played and VLC is able to launch, but with no audio. M4V and streams also refuse to load, but M4V can still be scrubbed through.

I am new to arch, I fully admit, but I am confused as to what package(s) being updated could lead to an issue on all these systems at once.

Attempts I have already made:

installing flashplugin jre gstreamer0.10-plugins ffmpeg.

updating packages again, including AUR packages with yay

reinstalling packages (pacman -Qqen > pkglist.txt, pacman --force -S $(< pkglist.txt)


Additional info:
pacman -Q > https://pastebin.com/U3Myvjp5

Brief specs: https://pastebin.com/9yKd9knA

Steps to reproduce: I am not sure what package/s might have caused such a system standstill. If you have done a full package update lately, check if you can watch streams, youtube videos, listen to audio, or watch M4V videos lately.
This task depends upon

Closed by  Buggy McBugFace (bugbot)
Saturday, 25 November 2023, 20:22 GMT
Reason for closing:  Moved
Additional comments about closing:  https://gitlab.archlinux.org/archlinux/p ackaging/packages/wireplumber/issues/1
Comment by Manvith Narahari (manvithn) - Wednesday, 06 April 2022, 07:13 GMT
I also ran into this issue after an update. It looks like you also have pulseaudio and pipewire installed at the same time. I was able to fix the issue by installing pipewire-pulse (which removes pulseaudio) and pipwire-alsa. After that VLC was able to play audio and videos were not frozen on browsers.
Comment by Sam (Samo____) - Thursday, 12 May 2022, 10:16 GMT
I am getting the same issue too, the video is buffered, but not played. Also i am getting this error while running from terminal`

[2022-05-12T09:53:23Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"

I tried the solution suggested by manvithn and it worked too
Comment by James Crompton (DonJaime) - Thursday, 12 May 2022, 11:29 GMT
This is probably due to wireplumber breaking pulseaudio after getting installed to replace pipewire-media-session to satisfy kwin's dependency on pipewire-session-manager while pipewire-media-session was unavailable. (see https://bbs.archlinux.org/viewtopic.php?id=276199) If you don't want to remove pulseaudio you can uninstall wireplumber (with dd to ignore dependencies) and reinstall pipewire-media-session, which is now available again.
Comment by Tobias Stolzmann (teiesti) - Thursday, 02 June 2022, 08:03 GMT
I ran into the same issue and can confirm that reinstalling pipewire-media-session (and thereby removing wireplumber) solves it. (See also https://archlinux.org/news/undone-replacement-of-pipewire-media-session-with-wireplumber/)
Comment by Appuchia (Appuchia) - Sunday, 07 May 2023, 12:58 GMT
I just ran into this issue today. Reinstalling pipewire-media-session also fixed it.