Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72947 - [foliate] crash on start caused by libsoup2/3

Attached to Project: Community Packages
Opened by Grzegorz (itsnotme) - Tuesday, 07 December 2021, 22:35 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 09 December 2021, 09:39 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Jerome Leclanche (Adys)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 5
Private No

Details

Description:
Foliate doesn't start. When ran from terminal, it shows:
```
itsnotme@notmypc:~$ export LC_ALL="C"
itsnotme@notmypc:~$ foliate
Gjs-Message: 22:58:05.129: JS WARNING: [resource:///com/github/johnfactotum/Foliate/js/main.js 23]: Requiring WebKit2 but it has 2 versions available; use imports.gi.versions to pick one

(com.github.johnfactotum.Foliate:13099): libsoup-ERROR **: 22:58:05.356: libsoup3 symbols detected. Using libsoup2 and libsoup3 in the same process is not supported.
Trace/breakpoint trap (core dumped)
```
This seems similar to  FS#72837 : https://bugs.archlinux.org/task/72837 . Unfortunately, downgrading libsoup to 2.74.1-1 and libsoup3 to 3.0.2-1 does not allow Foliate to start - it still crashes; this time with longer output (that is attached).


Additional info:
* foliate 2.6.3-1
* libsoup 2.74.2-1
* libsoup3 3.0.3-1


Steps to reproduce:
Ensure the packages have the versions specified above and just run Foliate.
This task depends upon

Comment by ludovit kramar (ludovitkramar) - Thursday, 16 December 2021, 15:29 GMT
I can confirm it happens, but it works correctly if gnome is not installed, seems like the presence of libsoup3 confuses foliate.
Comment by Fabian Bornschein (fabis_cafe) - Tuesday, 04 January 2022, 07:59 GMT
The fix/patch is in here:
https://github.com/johnfactotum/foliate/commit/8c00d67d57241bce965043fb98ba76782989eee5

For the PKGBUILD I'd also suggest to change the dependency from "webkit2gtk", to "libwebkit2gtk-4.0.so" so this will be seen before the transition was made to libsoup3 for the regular webkit2gtk package.
   PKGBUILD (1.3 KiB)
Comment by Fabian Bornschein (fabis_cafe) - Thursday, 13 January 2022, 12:46 GMT

Loading...