Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72661 - [xorg-server] Apps big scale

Attached to Project: Arch Linux
Opened by Amin Vakil (aminvakil) - Monday, 08 November 2021, 05:53 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 10 November 2021, 20:45 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:

Different applications like telegram-desktop, all kde applications, toolbars, konsole, etc. show apps abnormally big like you have set scale to 150% or something like that.

I've checked display configuration and it has not been changed, and scale is at 100%.

I'm using x11.

$ loginctl show-session 2 -p Type
Type=x11

Additional info:
xorg-server 21.1.1-2

Steps to reproduce:
Install xorg-server 21.1.1-2 from testing.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 10 November 2021, 20:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  21.1.1-3 reverts that commit back to previous behavior
Comment by Andreas Radke (AndyRTR) - Monday, 08 November 2021, 06:08 GMT
I've run into this as well. This is related to the DPI calculation changes. You need to make your setup use a fixed DPI setting and everything will work again.

https://wiki.archlinux.org/title/Xorg#Display_size_and_DPI
https://linuxreviews.org/HOWTO_set_DPI_in_Xorg#How_To_Permanently_Set_Your_Display_DPI
Comment by Amin Vakil (aminvakil) - Monday, 08 November 2021, 06:22 GMT
```
$ sudo cat /etc/X11/xorg.conf.d/40-dpi.conf
Section "Monitor"
Identifier "<default monitor>"
DisplaySize 508 285 # In millimeters
EndSection
```
This worked after a restart on my laptop screen, thanks!

Sometimes I use a LCD though (cannot test with it at the moment), does this change affect that too?
Comment by Laurent Carlier (lordheavy) - Monday, 08 November 2021, 17:46 GMT
Just reopening for a comment:

https://gitlab.freedesktop.org/xorg/xserver/-/issues/1241

There is a report about DPI issues in this bug report.
Comment by Tim Hilt (tim-hilt) - Wednesday, 10 November 2021, 17:03 GMT
  • Field changed: Percent Complete (100% → 0%)
Issue still persists with xorg-server 21.1.1-2. Why was this closed in the first place?
Comment by Antonio Rojas (arojas) - Wednesday, 10 November 2021, 17:04 GMT
Upstream is going to revert this behavior:

https://gitlab.freedesktop.org/xorg/xserver/-/issues/1241#note_1153655

so we may as well revert it already, since this is causing quite a stir judging by the multiple bug reports in different projects.

Loading...