Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71662 - [vivaldi] Browser white window (without adress bar)

Attached to Project: Community Packages
Opened by Michał Urbanek (skorpen) - Friday, 30 July 2021, 10:28 GMT
Last edited by Ike Devolder (BlackEagle) - Wednesday, 22 September 2021, 07:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I see white screen after turning on. Downgrade (downgrader -a vivaldi) to version 4.0.2312.41 make it workable. Cleaning Default folder not helps.
Additional info in incognito mode could be provided but they are only avaliable by (Ctrl+Shift+N).

Additional info:
* package version(s) 4.1.2369.11-1
* config and/or log files etc.
In console logs nothing special ( vaQuerySurfaceAttributes failed, VA error: invalid parameter ) nothing that should make browser not start correctly.
#7 0x00007f41d9c94259 start_thread (libpthread.so.0 + 0x9259)
#8 0x00007f41d8f055e3 __clone (libc.so.6 + 0xfe5e3)

Stack trace of thread 3917:
#0 0x00007f41d8f0592e epoll_wait (libc.so.6 + 0xfe92e)
#1 0x000056332d704ffd n/a (vivaldi-bin + 0x56eeffd)
#2 0x000056332d702af3 n/a (vivaldi-bin + 0x56ecaf3)
#3 0x000056332d5ad1d0 n/a (vivaldi-bin + 0x55971d0)
#4 0x000056332d54fab1 n/a (vivaldi-bin + 0x5539ab1)
#5 0x000056332d5209cb n/a (vivaldi-bin + 0x550a9cb)
#6 0x000056332d5671d8 n/a (vivaldi-bin + 0x55511d8)
#7 0x000056332d5673f5 n/a (vivaldi-bin + 0x55513f5)
#8 0x000056332d58c590 n/a (vivaldi-bin + 0x5576590)
#9 0x00007f41d9c94259 start_thread (libpthread.so.0 + 0x9259)
#10 0x00007f41d8f055e3 __clone (libc.so.6 + 0xfe5e3)

Stack trace of thread 3919:
#0 0x00007f41d8efd201 __select (libc.so.6 + 0xf6201)
#1 0x000056332d58d2e7 n/a (vivaldi-bin + 0x55772e7)
#2 0x000056332d58c590 n/a (vivaldi-bin + 0x5576590)
#3 0x00007f41d9c94259 start_thread (libpthread.so.0 + 0x9259)
#4 0x00007f41d8f055e3 __clone (libc.so.6 + 0xfe5e3)

Stack trace of thread 3918:
#0 0x00007f41d8f05f2a __xstat (libc.so.6 + 0xfef2a)
#1 0x000056332d57f413 n/a (vivaldi-bin + 0x5569413)
#2 0x000056332d582387 n/a (vivaldi-bin + 0x556c387)
#3 0x000056332df2249e n/a (vivaldi-bin + 0x5f0c49e)
#4 0x000056332de09638 n/a (vivaldi-bin + 0x5df3638)
#5 0x000056332d5644b4 n/a (vivaldi-bin + 0x554e4b4)
#6 0x000056332d5646c5 n/a (vivaldi-bin + 0x554e6c5)
#7 0x000056332d53d92f n/a (vivaldi-bin + 0x552792f)
#8 0x000056332d5552c7 n/a (vivaldi-bin + 0x553f2c7)
#9 0x000056332d554d92 n/a (vivaldi-bin + 0x553ed92)
#10 0x000056332d58be8e n/a (vivaldi-bin + 0x5575e8e)
#11 0x000056332d554a03 n/a (vivaldi-bin + 0x553ea03)
#12 0x000056332d5611df n/a (vivaldi-bin + 0x554b1df)
#13 0x000056332d560dad n/a (vivaldi-bin + 0x554adad)
#14 0x000056332d58c590 n/a (vivaldi-bin + 0x5576590)
#15 0x00007f41d9c94259 start_thread (libpthread.so.0 + 0x9259)
#16 0x00007f41d8f055e3 __clone (libc.so.6 + 0xfe5e3)

Steps to reproduce:
1. Update vivaldi to latest version
2. Run vivaldi (browser is unusable)
3. Logs are not very informative:
vaQuerySurfaceAttributes failed, VA error: invalid parameter only logs in journalctl -e shows some tracktrace
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Wednesday, 22 September 2021, 07:52 GMT
Reason for closing:  Fixed
Comment by Michał Urbanek (skorpen) - Friday, 30 July 2021, 10:38 GMT
Probably related to https://forum.vivaldi.net/topic/64487/today-s-4-1-2369-11-1-crashes-on-arch-linux

Suggested solution is

sudo systemctl stop systemd-resolved

sudo systemctl disable systemd-resolved

Still disabling services just to make browser seems like not good solution.
Comment by Nigel Kukard (nkukard) - Friday, 30 July 2021, 10:40 GMT
Chromium looks like it landed a fix referenced here...

https://github.com/systemd/systemd/issues/20111#issuecomment-883979766

Comment by Nigel Kukard (nkukard) - Friday, 30 July 2021, 10:41 GMT Comment by Michał Urbanek (skorpen) - Friday, 30 July 2021, 10:45 GMT
Related bugs:
https://bugs.archlinux.org/task/71568

as suggested downgrade is only known workaround for now.
Until https://bugs.chromium.org/p/chromium/issues/detail?id=1221442 get fixed
Comment by Michał Urbanek (skorpen) - Wednesday, 22 September 2021, 05:30 GMT
In Vivaldi 4.2.2406.48 with system update seems to get fixed and works for me.
Comment by Ike Devolder (BlackEagle) - Wednesday, 22 September 2021, 07:52 GMT
Thanks for letting us know

Loading...