Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71489 - [onionshare] crashes at start

Attached to Project: Community Packages
Opened by GI Jack (GI_Jack) - Monday, 12 July 2021, 15:40 GMT
Last edited by kpcyrd (kpcyrd) - Thursday, 14 October 2021, 22:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To kpcyrd (kpcyrd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
onionshare-gui, throws an error on boot and crashes

Additional info:
* package version(s)
$ pacman -Q onionshare
onionshare 2.2-5
$ pacman -Q python
python 3.9.6-1

Linux BOXNAME 5.12.14-hardened1-1-hardened #1 SMP PREEMPT Thu, 01 Jul 2021 17:41:06 +0000 x86_64 GNU/Linux


* config and/or log files etc.
Traceback (most recent call last):
File "/usr/bin/onionshare-gui", line 22, in <module>
onionshare_gui.main()
File "/usr/lib/python3.9/site-packages/onionshare_gui/__init__.py", line 142, in main
gui = OnionShareGui(common, onion, qtapp, app, filenames, config, local_only)
File "/usr/lib/python3.9/site-packages/onionshare_gui/onionshare_gui.py", line 172, in __init__
self.share_mode.init()
File "/usr/lib/python3.9/site-packages/onionshare_gui/mode/share_mode/__init__.py", line 48, in init
self.web = Web(self.common, True, "share")
File "/usr/lib/python3.9/site-packages/onionshare/web/web.py", line 77, in __init__
self.generate_static_url_path()
File "/usr/lib/python3.9/site-packages/onionshare/web/web.py", line 166, in generate_static_url_path
self.app.add_url_rule(
File "/usr/lib/python3.9/site-packages/flask/scaffold.py", line 56, in wrapper_func
return f(self, *args, **kwargs)
File "/usr/lib/python3.9/site-packages/flask/app.py", line 1092, in add_url_rule
raise AssertionError(
AssertionError: View function mapping is overwriting an existing endpoint function: static


* link to upstream bug report, if any

Steps to reproduce:
1. Open terminal
2. run onionshare-gui
This task depends upon

Closed by  kpcyrd (kpcyrd)
Thursday, 14 October 2021, 22:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in latest version
Comment by kpcyrd (kpcyrd) - Monday, 19 July 2021, 16:12 GMT
onionshare is currently incompatible with flask 2 unfortunately, this issue is already known upstream: https://github.com/micahflee/onionshare/issues/1365
Comment by Kevin Morris (kevr) - Thursday, 14 October 2021, 22:13 GMT
  • Field changed: Percent Complete (100% → 0%)
Essentially, due to how Arch Linux is rolling release, none of the original flask1-only packages in the repositories are compatible with the updates python-flask that uses >= 2, and so they're all broken. These packages should be moved off to the AUR, or a flask1 package should be rolled which these packages depend on instead.

Sure, it's an upstream issue that it's incompatible with Flask 2, but it's an Arch Linux issue that you no longer have Flask 1 and are still serving packages which use it.

Loading...