Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71346 - [pyalpm] 0.10.4-1 pyalpm.find_grp_pkgs segfaults

Attached to Project: Arch Linux
Opened by Sourav Das (souravdas142) - Thursday, 24 June 2021, 04:04 GMT
Last edited by Jelle van der Waa (jelly) - Thursday, 24 June 2021, 08:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

[powerpill AUR](https://aur.archlinux.org/packages/powerpill/) (A pacman wrapper, accelerate download speed of pacman) uses pyalpm.
And when I go to install any group with `powerpill -S plasma` or any group package the `segmentation` fault occured.

Workarround -

A recent version of [pm2ml](https://xyne.archlinux.ca/projects/pm2ml/index.html) solves the problem. But the developer on [upstream bugtracker comment](https://aur.archlinux.org/packages/powerpill/#comment-813618) says, its a workaround and need to be fixed in `pyalpm` itself

Additional info:
* pacman 6.0.0-3
* pyalpm 0.10.4-1
* [powerpill](https://aur.archlinux.org/packages/powerpill/) 2020.12.15-2
* [pm2ml](https://aur.archlinux.org/packages/pm2ml/) 2017.12-5
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

Install above with same version. and do a `powerpill -S plasma` or you can try to install any group package with `powerpill` , you can see the segfault.

This task depends upon

Closed by  Jelle van der Waa (jelly)
Thursday, 24 June 2021, 08:06 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#71261 

Loading...