Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70476 - package broadcom-wl-dkms loads wrong driver for BCM57788

Attached to Project: Community Packages
Opened by Johannes Kamprad (killajoe) - Friday, 16 April 2021, 16:17 GMT
Last edited by Alexander F. Rødseth (xyproto) - Sunday, 16 May 2021, 20:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
having broadcom-wl-dkms installed will make device BCM57788 unusable

Additional info:
* package version(s)= broadcom-wl-dkms 6.30.223.271-26


Steps to reproduce:

installing broadcom-wl-dkms if broadcom-wl-dkms is present on system.

Ethernet (wired) is not detected, or wrong non working driver is selected (false detection)

After uninstalling broadcom-wl-dkms and reloading modules like so:

```
rmmod tg3
modprobe broadcom
modprobe tg3
```
device is detected and able to connect again, and showing this:
`Device-1: broadcom-wl-dkms Gigabit Ethernet PCIe driver: tg3`

This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Sunday, 16 May 2021, 20:43 GMT
Reason for closing:  Upstream
Additional comments about closing:  Removed the blacklist entry
Comment by Alexander F. Rødseth (xyproto) - Friday, 07 May 2021, 14:14 GMT
Thanks for reporting. It could be that too many modules are blacklisted when installing the broadcom-wl-dkms package. I'm not on a machine with Broadcom hardware right now.

Do you happen to know if not blacklisting one or more of these kernel modules in broadcom-wl-dkms.conf and then rebooting fixes this issue?

b43
b43legacy
ssb
bcm43xx
brcm80211
brcmfmac
brcmsmac
bcma
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 12 May 2021, 10:32 GMT
I added a note to the .install file output + blacklisted the tg3 kernel module in broadcom-wl-dkms.conf.

Unfortunately, broadcom-wl-dkms is unmaintained non-open-source software with a custom license. It has been patched heavily since Linux 4.7 and it's not straightforward to make it play well with other parts of Linux.

Please re-open this issue if there are better solutions available.
Comment by David Bohman (debo) - Sunday, 16 May 2021, 16:31 GMT
  • Field changed: Percent Complete (100% → 0%)
Why did we blacklist tg3? It is needed for ethernet.
Comment by David Bohman (debo) - Sunday, 16 May 2021, 16:37 GMT
Related to  FS#70907 . This change broke ethernet on my machine. I need tg3 and this driver on my machine. I propose that we back out this change, and if tg3 is conflicting on the reporter's machine, the correct approach is to blacklist tg3 on that machine.
Comment by David Bohman (debo) - Sunday, 16 May 2021, 16:50 GMT
On my machine, this is the device which requires tg3:

02:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe (rev 10)
Subsystem: Broadcom Inc. and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe
Kernel driver in use: tg3
Kernel modules: tg3

There does not appear to be a conflict, both devices function properly when the blacklist of tg3 is removed.

Loading...