Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70293 - libxkbcommon 1.2.0-1 breaks keyboard input in qt applications

Attached to Project: Arch Linux
Opened by Alessandro Caputo (Alexpin) - Monday, 05 April 2021, 08:07 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 07 April 2021, 08:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: upgrading libxkbcommon and libxkbcommon-x11 to v 1.2.0-1 breaks input in qt/kde applications (tested with okular, qutebrowser, anki, pinentry-qt).
Downgrading to 1.1.0-2 promptly fixes the bug.

pinentry-qt complains of "qt.qpa.xkeyboard: failed to compile a keymap"

Steps to reproduce:
- upgrade libxkbcommon to version 1.2.0-1
- launch a qt application
- try using the keyboard to do something

p.s. this might be a bigger problem if it breaks whole desktop environments, e.g. KDE.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 07 April 2021, 08:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.2.0-2
Comment by Jan Alexander Steffens (heftig) - Monday, 05 April 2021, 10:30 GMT Comment by Jan Alexander Steffens (heftig) - Monday, 05 April 2021, 10:47 GMT
I can't reproduce this, at least in GNOME, with Qt's xcb backend. This might be something very specific to your settings, e.g. the exact configured keymap.
Comment by Gabor Hauzer (cysp74) - Monday, 05 April 2021, 11:05 GMT
I can confirm, same issue is here. However pretty weird, because have two box with almost the same config, but only one is failing.

Checked:
Environment variables - not found relevant difference.
Dconf (using gnome) - not found relevant difference.
Trolltech conf, etc - not found relevant difference.
/etc - not found relevant difference.

Failing qt apps eg: doublecmd, flacon, telegram, keepassxc

But on the box where I'm facing this issue, qemu is installed, and installed brltty as auxiliary package... Perhaps?
Comment by Alessandro Caputo (Alexpin) - Tuesday, 06 April 2021, 07:36 GMT
I also have two boxes and I'm facing the problem only on one of them. Might it be a multilib issue? (The multilib repo is enabled only on the box that faces the problem, and perhaps that's the case of the previous comment as well?)
Comment by marius (4984) - Tuesday, 06 April 2021, 14:29 GMT
Same here, three seemingly identical installations, one of them (macbook 2013) shows this behaviour.
Comment by Jan Alexander Steffens (heftig) - Tuesday, 06 April 2021, 14:38 GMT
Maybe try running an application with XKB_LOG_LEVEL=debug XKB_LOG_VERBOSITY=10 and then compare between a working and a broken setup.
Comment by leroy (usrnm-_.) - Tuesday, 06 April 2021, 15:15 GMT
Possible additional step to reproduce: set the xkb option "numpad:mac". Removing this option allowed qt apps to receive keyboard input (this is with a standard pc keyboard model, us layout).
Comment by Andrew Pilsch (oncomouse) - Tuesday, 06 April 2021, 15:18 GMT
I'm having similar problems (errors relating to keymap compilation) but not in Qt/KDE. The problems for me occur in AwesomeWM, Rofi, and Kitty. Here is the output when I run "env XKB_LOG_LEVEL=debug XKB_LOG_VERBOSITY=10 rofi":

xkbcommon: DEBUG: Include path failed: /home/andrew/.config/xkb (No such file or directory)
xkbcommon: DEBUG: Include path failed: /home/andrew/.xkb (No such file or directory)
xkbcommon: DEBUG: Include path failed: /etc/xkb (No such file or directory)
xkbcommon: DEBUG: Include path added: /usr/share/X11/xkb
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5079:46: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5081:48: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5083:48: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5087:47: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5089:46: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5097:48: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5101:46: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5103:46: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5107:45: this compose sequence is a duplicate of another; skipping line
xkbcommon: WARNING: /usr/share/X11/locale/en_US.UTF-8/Compose:5110:46: this compose sequence is a duplicate of another; skipping line
xkbcommon: DEBUG: created compose table from locale en_US.UTF-8 with path /usr/share/X11/locale/en_US.UTF-8/Compose

(process:25700): X11Helper-WARNING **: 10:14:51.685: Failed to get Keymap for current keyboard device.

And "env XKB_LOG_LEVEL=debug XKB_LOG_VERBOSITY=10 kitty":

xkbcommon: DEBUG: Include path failed: /home/andrew/.config/xkb (No such file or directory)
xkbcommon: DEBUG: Include path failed: /home/andrew/.xkb (No such file or directory)
xkbcommon: DEBUG: Include path failed: /etc/xkb (No such file or directory)
xkbcommon: DEBUG: Include path added: /usr/share/X11/xkb
[096 10:17:00.101497] [glfw error 65544]: Failed to compile XKB keymap
GLFW initialization failed
Comment by Jan Alexander Steffens (heftig) - Tuesday, 06 April 2021, 17:33 GMT
It would be nice if someone who is affected could git bisect between xkbcommon-1.1.0 and xkbcommon-1.2.0 to find the bad commit.
Comment by leroy (usrnm-_.) - Tuesday, 06 April 2021, 19:08 GMT
From 1.1.0+1+g40c00b4, qt is broken for me (w/ "setxkbmap -option numpad:mac"). https://github.com/xkbcommon/libxkbcommon/commit/40c00b472144d1684d2fb97cafef39ef59f21b28
Comment by Jan Alexander Steffens (heftig) - Tuesday, 06 April 2021, 21:34 GMT

Loading...