Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#70117 - [gjs] 2:1.68.0-1 causes GNOME session to crash when Element and gajim are started together

Attached to Project: Arch Linux
Opened by Pascal Ernster (hardfalcon) - Sunday, 21 March 2021, 20:13 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 07 May 2021, 16:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 27
Private No


gjs 2:1.68.0-1 causes the whole GNOME session to crash when Element and gajim are started together. The order in which both programs are started doesn't seem to matter, but a few seconds after the second of both (whichever it is) has been launched, the whole GNOME session crashes and I'm back at the login screen.

I'm not sure what exactly is causing this, but downgrading to gjs 2:1.66.2-1 from extra made the issue go away.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 07 May 2021, 16:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  gjs 2:1.68.1-1
Comment by Frederic Bezies (fredbezies) - Sunday, 21 March 2021, 20:32 GMT
I have the same problem when launching Qemu - using VirtManager - and another software like Discord or Quodlibet. You'll find a lot of log in this bug report:
Comment by Pascal Ernster (hardfalcon) - Sunday, 21 March 2021, 20:45 GMT
I use gnome-shell-extension-appindicator, and the crashes don't occur anymore when I disable that specific extension using gnome-tweaks. Both Element and gajim have an appindicator/"systray" icon which will end up using that extension if it is enabled.
Comment by Pascal Ernster (hardfalcon) - Sunday, 21 March 2021, 20:46 GMT
fredbezies: VirtManager also has an appindicator icon, I don't know about Discord and Quodlibet, though.
Comment by Frederic Bezies (fredbezies) - Sunday, 21 March 2021, 21:55 GMT
They have one too. I'm using this extension: to have tray icons to switch easily between apps.

Having to remove this extension is not really an option for me. Anyway if this application is related to the crash, well, I will deactivate it.
Comment by Cristian C. (ckristi) - Monday, 22 March 2021, 22:31 GMT
Same happens here, and also seems related to the appindicator extension, installed from the community repo:
gnome-shell-extension-appindicator 35-1

Also, as mentioned in the original post, downgrading gjs to 1.66.2-1 works around the issue.
Comment by Varakh (Varakh) - Tuesday, 23 March 2021, 08:42 GMT
I also have the very same issue. On top of that, each time it segfaults GNOME states that GNOME Display Manager is required but I guess that's due to my startx setup.

Is this something the appindicator needs to fix?
Comment by bbo2adwuff (bbo2adwuff) - Tuesday, 23 March 2021, 09:40 GMT
2:1.68.0-2 was not an attempt to fix this issue, right?
Because here GNOME still crashes.

When I just disable all GNOME user extensions GNOME session doesn't crash anymore.
`gsettings set disable-user-extensions true`
Comment by Pascal Ernster (hardfalcon) - Tuesday, 23 March 2021, 09:43 GMT
Varakh, bbo2adwuff: Which GNOME shell extensions are you using? That info might be helpful in finding out if it's a bug in gnome-shell-extension-appindicator or a more generic problem with gjs 1.68.0.
Comment by Varakh (Varakh) - Tuesday, 23 March 2021, 09:45 GMT Comment by Pascal Ernster (hardfalcon) - Tuesday, 23 March 2021, 09:51 GMT
Can you try disabling only "" but enabling enabling all of the other extensions, re-login into GNOME and check if that makes the crashes stop on your machine?
Comment by bbo2adwuff (bbo2adwuff) - Tuesday, 23 March 2021, 10:43 GMT Comment by Varakh (Varakh) - Tuesday, 23 March 2021, 11:17 GMT
Disabling works for me, but as bbo2adwuff stated, maybe it's not just this extension.

Thanks for diving into this hardfalcon.

PS: I don't know, but without appindicator, no single app which uses such an icon is shown. Personally I cannot deal with that, especially apps which act like a background service need this, e.g. Nextcloud, Syncthing. Still don't know why GNOME devs are strictly against it. So for me I'll for now ignore the gjs update. :/
Comment by px (gofree) - Tuesday, 23 March 2021, 11:23 GMT Comment by Lorenzo (qwisatz) - Wednesday, 24 March 2021, 15:23 GMT
Just to confirm the bug. It's not only appindicator. I didn't downgrade to 1.66* but since I need some sort of app indicator on the tray I left enabled only Tray Icons reloaded and disabled Kstatusnotifier. Crashes *seem* to be gone...for now.
Comment by George (Vash63) - Wednesday, 24 March 2021, 17:16 GMT Comment by Pascal Ernster (hardfalcon) - Wednesday, 24 March 2021, 17:23 GMT Comment by Tim Teichmann (tauly) - Wednesday, 24 March 2021, 19:31 GMT
... and the pending merge request attempting to fix this:
Comment by Mathijs van Veluw (BlackDex) - Tuesday, 30 March 2021, 08:33 GMT
I have the same issue, fixed by downgrading to 1.66 for now.
Comment by Cristian C. (ckristi) - Tuesday, 20 April 2021, 07:05 GMT
I saw 1.68.0-3 is now available, is it fixing this issue?
Comment by Mathijs van Veluw (BlackDex) - Tuesday, 20 April 2021, 13:16 GMT
Well gjs 1.68.0-3 breaks my extensions again. I can't use any extension, also with extensions on it will break the lockscreen.

So i needed to revert back to 1.66.2-1 for gjs and 40.0+39 for gnome-shell.
Comment by Mark Wagie (yochananmarqos) - Tuesday, 20 April 2021, 15:00 GMT
@Mathijs: Try toggling Extensions off/on after logging in then try locking the screen.
Comment by Mathijs van Veluw (BlackDex) - Wednesday, 21 April 2021, 08:38 GMT
@Mark i tried your suggestion, but it doesn't resolve the issue.
I have also tried to turn of all extensions but one or two and keep testing.
Sometimes it works for a few moments and after a while it somehow breaks. I haven't tried removing the extensions as a whole, because maybe there are some checks done by these extensions which causes an issue in the background.

So i still downgraded it, which seems to work for me right now, though i which to upgrade of course.
Comment by Cristian C. (ckristi) - Saturday, 24 April 2021, 11:35 GMT
As a matter of fact I have just removed gjs from the ignore list and upgraded to 1.68.0-3. I saw no crashes in the last 12 hours of mild usage of the laptop, but I am only having enabled the appindicator extension (gnome-shell-extension-appindicator).
Comment by Yann Jorelle (yannjor) - Tuesday, 27 April 2021, 10:49 GMT
Shell is still crashing for me with 1.68.0-3. On the other hand, desktop background is not working with 1.66.2... I noticed the fix got merged on gitlab. Hoping a new version comes soon.
Comment by Massimo Branchini (max.bra) - Thursday, 29 April 2021, 09:12 GMT
All this type of bugs/crash seems to be fixed with this:

I was afflicted by 'toggling down object GSettings that's already queued to toggle up' gnome-shell crash bug.

I've recompliled gjs package to 43aa4ac32a6f76d4abc592956e55a396cf6bf0b3 (last one just in case...) commit and all is working here.
Comment by Mark Wagie (yochananmarqos) - Thursday, 29 April 2021, 16:33 GMT
I can confirm building with that commit solves the issue.
Comment by Pascal Ernster (hardfalcon) - Friday, 07 May 2021, 16:43 GMT
gjs 2:1.68.1-1 fixes the issue for me.