Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#66296 - [waybar] optional dependency on libappindicator-gtk3

Attached to Project: Community Packages
Opened by Johannes (pinsl) - Saturday, 18 April 2020, 15:20 GMT
Last edited by Brett Cornwall (ainola) - Wednesday, 20 October 2021, 05:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Brett Cornwall (ainola)
Maxim Baz (maximbaz)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Optional dependency libappindicator-gtk3 is missing.

Output from waybar:

[warning] For a functional tray you must have libappindicator-* installed and export XDG_CURRENT_DESKTOP=Unity
This task depends upon

Closed by  Brett Cornwall (ainola)
Wednesday, 20 October 2021, 05:49 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Waybar already has a dependency on libappindicator-gtk3, so there would be no need for an optional dependency. Setting XDG_CURRENT_DESKTOP=Unity is not something we're going to do as that has potential to really screw with things.
Comment by Kevin Morris (kevr) - Thursday, 14 October 2021, 22:28 GMT
This seems to be an issue for me with waybar 0.9.8-1 and libappindicator-gtk3 12.10.0.r296-1. The issue seems to persist with waybar-git from the AUR.
Comment by Brett Cornwall (ainola) - Monday, 18 October 2021, 00:41 GMT
Hi, kevr! I'm a little confused: Waybar already has a dependency on libappindicator-gtk3, so there would be no need for an optional dependency. Setting XDG_CURRENT_DESKTOP=Unity is not something we're going to do as that has potential to really screw with things.

Am I missing something about what this ticket was supposed to say?

Loading...