Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65539 - [opera] 66.0.3515.72 gives random 'Page Crashed' errors after glibc upgrade to 2.31

Attached to Project: Community Packages
Opened by Chris (emulti) - Tuesday, 18 February 2020, 11:42 GMT
Last edited by Ike Devolder (BlackEagle) - Tuesday, 25 February 2020, 13:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After upgrade to latest Opera 66.0.3515.72-1 tabs randomly crash with message asking to refresh page to continue.
Possibly caused by html5 video elements (unconfirmed)

A report on the Opera forums identified the recent upgrade to glibc and lib32-glibc to V.2.31 as a potential cause.
See https://forums.opera.com/topic/38293/opera-66-0-3515-72-1-crashing-without-any-extension-or-new-installation/58
A user recommended downgrade of glibc and lib32-glibc to 2.30, and this appears to have stopped the tab crashes.

Additional info:
* package version(s) opera 66.0.3515.72-1, opera-ffmpeg-codecs 79.0.3945.130-1 glibc 2.31-1, lib32-glibc 2.31-1

Issue apprears solved by downgrade of glibc/lib32-glibc to 2.30-3 (though obviously this may introduce issues with oother packages built with glibc 2.31)

* config and/or log files etc.
* link to upstream bug report, if any
https://forums.opera.com/topic/38293/opera-66-0-3515-72-1-crashing-without-any-extension-or-new-installation/58

Steps to reproduce:
Run Opera restoring previously open tabs,any of open tabs gives 'Page has crashed' warning apparently randomly. Crash may recur after refresh after random interval.
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Tuesday, 25 February 2020, 13:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  I have no more segfaults in dmesg from opera with opera 67.0.3575.31-1
Comment by Frank Uebbing (quiqueck) - Wednesday, 19 February 2020, 06:58 GMT
When starting opera on a command line it says:

**CRASHING**:seccomp-bpf failure in syscall 0230

From my understanding this is an issue of chrome/chromium, see: https://bugs.chromium.org/p/chromium/issues/detail?id=1025739

I didn't found any information on which release of chromium opera was build upon, so i guess opera has to use the latest chromium sources to fix this issue.
Comment by Chris (emulti) - Friday, 21 February 2020, 10:35 GMT
  • Field changed: Percent Complete (100% → 0%)
Unfortunately, the issue does not seem to be fixed.
After pacman -Syu to install new versions of opera and opera-ffmpeg-codecs along wih glibc/lib32-glibc 2.31, the random page crashes return.
Recovered by forced downgrade to glibc-2.30-3/lib32-glibc-2.30-3
Guess we have to wait for upstream
Comment by Ike Devolder (BlackEagle) - Saturday, 22 February 2020, 09:08 GMT
yeah, then we will have to wait for upstream, but this could take a while because I think they use ubuntu as build base
Comment by Ike Devolder (BlackEagle) - Tuesday, 25 February 2020, 12:54 GMT
It looks like the segfaults don't apprear anymore with opera 67.0.3575.31

Loading...