Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65257 - [wpa_supplicant] Commit 3337d901e02dc38e95b23b714747b0384b2e5171 broke Broadcom WiFi

Attached to Project: Arch Linux
Opened by Ben Kerry (bkerry) - Friday, 24 January 2020, 16:44 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 24 January 2020, 20:43 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hello, this is my first bug report. Please be gentle.

Additional info:
* kernel version: 5.4.14-arch1-1
* package version: wpa_supplicant-2:2.9-4-x86_64
* related forum thread: https://bbs.archlinux.org/viewtopic.php?id=235916
* logs in attachment

Steps to reproduce:
Upgrading from wpa_supplicant-2:2.9-3-x86_64 to wpa_supplicant-2:2.9-4-x86_64 broke the WiFi on my Dell XPS 13 with Broadcom BCM4352 WiFi card. The issue seems to be caused by the newly added compile time option `CONFIG_MESH=y` introduced with commit 3337d901e02dc38e95b23b714747b0384b2e5171 (https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/wpa_supplicant&id=3337d901e02dc38e95b23b714747b0384b2e5171). Compiling `wpa_supplicant` without this option fixed the issue for me.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 24 January 2020, 20:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  wpa_supplicant 2:2.9-5
Comment by Kirill (SamuraiJack) - Friday, 24 January 2020, 20:22 GMT
Same here

Loading...