Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#6292 - 0.8 ISO does not boot on some hardware

Attached to Project: Arch Linux
Opened by Maik Opitz (Schrauber) - Saturday, 27 January 2007, 21:42 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 28 January 2007, 16:49 GMT
Task Type Bug Report
Category Installation
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

On my laptop the 0.8 ISOs wont boot. I tried diffent mothods to burn the images (TAO,DAO,DAO96). Also I tried the base and the full image. Same problems.

If I boot from 0.8 disk, I get only a grub shell (grub>).
The workaround was, to install the kernel from the install disk to a harddrive partition an boot from there in the installation system.

I tried on other computers. There the disk works fine.
Its not a hardware fault, because my laptop boots normally fine from CD. Even from linux install disks (Ubuntu and such).

I attached the output of lspci.
My hardware is a Fujitsu Siemens Amilo K7600 notebook. The CD-ROM is an QSI CDRW/DVD SBW242B.
   lspci (1 KiB)
This task depends upon

This task blocks these from closing
 FS#6031 - 0.8 installation ISO showstoppers 
Closed by  Tobias Powalowski (tpowa)
Tuesday, 27 February 2007, 06:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed by isolinux usage
Comment by Tobias Powalowski (tpowa) - Sunday, 28 January 2007, 08:29 GMT
have you tried to modify the grub entries?
perhaps the cdrom is just on an other port for grub, try to change the grub entries by hittin 'e' on menu and change it to your setup.
Comment by Maik Opitz (Schrauber) - Sunday, 28 January 2007, 15:39 GMT
Hi,

I think you did not get me right.
There are no entrys to edit. I do not geht the normal boot selection screen.
I directly get a simple grub shell.
The only line on screen:
grub> _
thats all.
Comment by Tobias Powalowski (tpowa) - Sunday, 28 January 2007, 16:49 GMT
assigning to thomas, perhaps he has an idea whats going wrong
Comment by Thomas Bächler (brain0) - Sunday, 28 January 2007, 17:05 GMT
grub looks for a grub configuration file on (cd)/boot/grub/menu.lst

Can you enter 'configfile (cd)/boot/grub/menu.lst' on the grub shell? If that doesn't work, please enter 'root (<tab><tab>' and tell us which devices are listed. If there is no (cd) device among them, we may be in trouble.
Comment by Maik Opitz (Schrauber) - Sunday, 28 January 2007, 17:37 GMT
OK, here we go:

configfile (cd)/boot/grub/menu.lst gives
Error 23: Error while parsing number

root (<tab> gives
Possible disks are: fd0 fd1 fd2 fd3 fd4 fd5 fd6 fd7 hd0

So no cd there. And the thing is, there are 7 fd entrys. But I have not one floppy in this computer.
Comment by Thomas Bächler (brain0) - Sunday, 28 January 2007, 17:57 GMT
Can you look what is inside those fdX devices? Try cat (fd0)/<tab> or so.


BTW, weird thing about this is that you can boot isolinux-based CDs (I assume Ubuntu uses isolinux), which use the same boot mechanism as grub's stage2_eltorito (called "no emulation" mode).
Comment by Maik Opitz (Schrauber) - Sunday, 28 January 2007, 18:38 GMT
cat on the fd's gives me
Error 25: Disk read error

On hd0 gives a mount filesystem error. But thats clean, because the first partition ist ntfs.

I never had such problems with bootable disks before. I tried some. All the Ubuntus are no problem. Also Suse is no problem. Makedrake. And of course Windows *lol*
Comment by Thomas Bächler (brain0) - Sunday, 28 January 2007, 19:27 GMT
Is this CD drive builtin, or attached to USB/CardBus/...?
Comment by Maik Opitz (Schrauber) - Sunday, 28 January 2007, 21:31 GMT
Its builtin. It is the original drive of this notebook. Connected through IDE.
Chipset is a VIA KM266.
Comment by 甘露(Lu Gan) (ganlu) - Thursday, 01 February 2007, 13:02 GMT
Do you have a usb/removable disk plugged in? I have the similar problem with my usb harddisk attached when installing 0.8.
Comment by Maik Opitz (Schrauber) - Thursday, 01 February 2007, 13:31 GMT
No, no devices plugged in.

I just testet, what devices the installed grub on harddisk can see. These are the same. No cd. So I think, its a fault of grub.
Comment by Papadopoulos, Mihail (scarecrow) - Monday, 05 February 2007, 19:55 GMT
It does not boot on my system, either (grub returns a parsing error 23 and the CD-ROM drive isn't initialized). Asus P5B mainboard with Jmicron controller.
Same problem encountered with virtually all distributions that use grub instead of isolinux (isolinux based CD's boot properly). So far, I do not know a cure for that issue. Actually Ubuntu Feisty has switched from Grub back to Isolinux because of this particular issue...
Comment by Thomas Bächler (brain0) - Tuesday, 06 February 2007, 21:07 GMT
I think we will have to provide at least the base CD with isolinux as a fallback.
Comment by Shang (shang) - Tuesday, 06 February 2007, 21:33 GMT
I have exact the same problem. There is only a grub shell. My laptop is pretty old. (P3 850mhz). Sometimes I had problems booting some CDs (No emulation mode), but the most CDs worked. (Ubuntu 5.04-6.10)

When I type: root ( <TAB> , there is only my harddisk.

The 0.7.2 CD worked.
Comment by Papadopoulos, Mihail (scarecrow) - Wednesday, 07 February 2007, 15:40 GMT
Hi shang, I'm hardly surprised that 0.7.2 worked- it is mastered with isolinux as loader.
Same applies with all 0.8 alphas up to the 17-12-06 one which was tha last one using isolinux. All of them boot my system with no issues at all.
Then came grub as loader, and the CD failed to boot the system anymore...
OK, I know things evolve all the time, but since grub does have issues with quite a few hardware configurations, and since it's not THAT a great deal switching back to (working/tested) isolinux, why not giving grub a miss ATM, and opt for maximum hardware compatibility?
Comment by Glenn Matthys (RedShift) - Tuesday, 13 February 2007, 13:06 GMT
What are the advantages of using GRUB over isolinux? Unless there are very convincing arguments we should use isolinux.
Comment by Thomas Bächler (brain0) - Wednesday, 14 February 2007, 08:11 GMT
GRUB has a menu. With GRUB, you can boot any installed system directly. With GRUB, you can reinstall GRUB to the MBR directly. It's just more comfortable for an install and rescue CD.
Comment by Glenn Matthys (RedShift) - Wednesday, 14 February 2007, 08:15 GMT
But grub is available after boot too. And users can just mount their disks and chroot and they'll be able to reinstall grub.
Comment by Tobias Powalowski (tpowa) - Saturday, 24 February 2007, 08:56 GMT
beta2 isos are now using isolinux again, to avoid non booting media

Loading...