Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61461 - [libpgm] Installed pkg-config directs compilers to use a non-existent include directory

Attached to Project: Community Packages
Opened by Alex (bidski) - Saturday, 19 January 2019, 09:57 GMT
Last edited by Antonio Rojas (arojas) - Monday, 07 October 2019, 21:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: The installed pkg-config file contains an include difrectory entry for the non-existent folder /usr/lib/pgm-5.2/include. This can cause cmake to fail when building libraries which depend libpgm (may only come up transitively, see below).

Additional info:
* package version(s)
* config and/or log files etc.

I encountered this error while building the ignition-transport package from AUR. ignition-transport depends on zeromq which, in turn, depends on libpgm. When cmake is configuring the build environment for ignition-transport the following output is observed

CMake Error in src/CMakeLists.txt:
Imported target "ZeroMQ::ZeroMQ" includes non-existent path

"/usr/lib/pgm-5.2/include"

in its INTERFACE_INCLUDE_DIRECTORIES. Possible reasons include:

* The path was deleted, renamed, or moved to another location.

* An install or uninstall procedure did not complete successfully.

* The installation package was faulty and references files it does not
provide.

Upon inspection "/usr/lib/pgm-5.2/include" comes from /usr/lib/pkgconfig/openpgm-5.2.pc which contains this line

Cflags: -I${includedir}/pgm-5.2 -I${libdir}/pgm-5.2/include

Removing the second -I term will resolve the error that cmake reports.

Steps to reproduce: Install libpgm
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 07 October 2019, 21:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  libpgm 5.2.122-4
Comment by Alex (bidski) - Saturday, 19 January 2019, 10:14 GMT
Package versions:
community/libpgm 5.2.122-3
community/zeromq 4.3.1-1
extra/cmake 3.13.2-1
ignition-transport 4.0.0-1
Comment by Karlis Senko (karliss) - Saturday, 02 March 2019, 08:25 GMT Comment by Anton Leontiev (bunder) - Friday, 29 March 2019, 08:02 GMT Comment by Alex Dewar (billypilgrim) - Thursday, 11 July 2019, 11:27 GMT
Is there any chance the maintainer could take a look at this? The issue has been open for 7 months now and it it'll only take a minute to fix.
Comment by Cove Geary (covegeary) - Monday, 16 September 2019, 12:28 GMT
Seconding the request for the maintainer to take a look. This seems like a long-standing issue. (I encountered this when trying to build ignition-transport. Similar to https://forum.manjaro.org/t/error-compiling-ignition-transport/74837/8)
Comment by Gregory Land (ModYokosuka) - Saturday, 05 October 2019, 19:57 GMT
I am also running into this issue while trying to fix a AUR package called xeus. After looking into the github page for openpgm, abd it looks like the project is active but, a release has not occurred in 6 years!? ( https://github.com/steve-o/openpgm/issues/62 ) This problem has a fix in upstream already ( https://github.com/steve-o/openpgm/commit/ee25ff3d13f2639b4c3a42125e79f77f921c3320 ) but the lack of releases have prevented it from being pushed down to arch. Could we have this bug fix patched in instead of waiting around for upstream to release?
Comment by Gregory Land (ModYokosuka) - Monday, 07 October 2019, 20:08 GMT
I have attached an updated PKGBUILD and .patch file that will resolve the issue. I have posted on the issue tracker for upstream prodding for a new release. Since no timeline exists for when that might occur, if ever, it seems like pulling in this change is the only option.

Loading...