FS#60210 - [texlive-core] latexindent is missing perl dependencies

Attached to Project: Arch Linux
Opened by hexchain (hexchain) - Wednesday, 26 September 2018, 19:00 GMT
Last edited by Antonio Rojas (arojas) - Monday, 29 May 2023, 12:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 30
Private No


The latex-indent tool in texlive-core is missing (a lot of) Perl dependencies.

Additional info:
* package version(s)
* config and/or log files etc.

texlive-core 2018.48566-1

$ latexindent
Can't locate Log/Log4perl.pm in @INC (you may need to install the Log::Log4perl module) (@INC contains: /usr/share/texmf-dist/scripts/latexindent /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at /usr/share/texmf-dist/scripts/latexindent/LatexIndent/LogFile.pm line 22.
BEGIN failed--compilation aborted at /usr/share/texmf-dist/scripts/latexindent/LatexIndent/LogFile.pm line 22.
Compilation failed in require at /usr/share/texmf-dist/scripts/latexindent/LatexIndent/Document.pm line 25.
BEGIN failed--compilation aborted at /usr/share/texmf-dist/scripts/latexindent/LatexIndent/Document.pm line 25.
Compilation failed in require at /usr/bin/latexindent line 27.
BEGIN failed--compilation aborted at /usr/bin/latexindent line 27.
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 29 May 2023, 12:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  git commit 81b2147
Comment by Jun Bo Bi (jambon) - Wednesday, 27 March 2019, 14:14 GMT
Here are all the missing dependencies: perl-log-log4perl perl-file-homedir perl-log-dispatch perl-namespace-autoclean perl-specio perl-eval-closure perl-params-validationcompiler perl-yaml-tiny perl-unicode-linebreak
Comment by Max Ammann (maxammann) - Thursday, 04 April 2019, 12:49 GMT
Having the same problem. Shouldn't these packages all be packaged because they are dependencies of latexindent?
Comment by Ashwin Vishnu (jadelord) - Wednesday, 05 June 2019, 13:10 GMT
I stumbled over the same problem perl-log-dispatch is only available via AUR.
Comment by Simon Thiel (thielsn) - Thursday, 09 January 2020, 11:05 GMT
The issue is still not resolved. Please add the dependencies, it does not make much sense to have the tool half-installed.
Comment by Alex (Sinax) - Monday, 17 February 2020, 16:12 GMT
Seems like a relatively easy thing to fix, I hope the perl modules will be included in the future.
Comment by Mathias Anselmann (matse) - Thursday, 30 April 2020, 10:04 GMT
Still an issue, installing the packages mentioned by jambon solves the problem.
Comment by Bruno Pagani (ArchangeGabriel) - Wednesday, 06 May 2020, 20:23 GMT
Those should be optdeps at most, but that’s a lot of them to list. Or maybe split it out as its own package? If it’s not required for other core tools…
Comment by Jun Bo Bi (jambon) - Wednesday, 06 May 2020, 21:06 GMT
It's best if it's split into its own package, since it doesn't make sense for a tool to be half installed. Plus it's not required for other core tools.
Comment by Dan Shick (dan.shick) - Wednesday, 10 February 2021, 16:09 GMT
This package in the AUR seems to do the trick in the mean time.
Comment by Grigorios (Grigorios) - Friday, 29 April 2022, 09:55 GMT
Hello, this problem still exists today. I managed to get latexindent working by installing perl-yaml-tiny and perl-file-homedir. Those were the missing dependencies on my side.

Initially I installed the texlive-most group.
Comment by Arvid Norlander (VorpalGun) - Monday, 12 December 2022, 13:09 GMT
Hi, I ran into this, and it is still a problem.