Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59987 - [syslinux] Hardware Information (HDT) broken

Attached to Project: Arch Linux
Opened by Matthias Lisin (matthias.lisin) - Saturday, 08 September 2018, 18:51 GMT
Last edited by Anatol Pomozov (anatolik) - Sunday, 24 November 2019, 18:48 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

ISO: 2018.09.01

In the latest ArchLinux ISO the "Hardware Information (HDT)" in the boot menu is broken.
Of course this only happens when booting via BIOS, since UEFI doesn't provide this feature.

Steps to reproduce:
1. Boot ArchLinux ISO via BIOS (NOT UEFI!)
2. Select menu item "Hardware Information (HDT)"
3. Get "Undef symbol FAIL" error (see attached Screenshot)


I managed to reproduce this on a Sony VAIO (VPCEB4J1E) and VirtualBox.
These are also the only things I tried it on.
Very confident that this is an issue on every other device and VM-Software.

This task depends upon

Closed by  Anatol Pomozov (anatolik)
Sunday, 24 November 2019, 18:48 GMT
Reason for closing:  Fixed
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 09 September 2018, 00:04 GMT
  • Field changed: Attached to Project (Release Engineering → Arch Linux)
Comment by Anatol Pomozov (anatolik) - Monday, 10 September 2018, 16:09 GMT
I do not see these changes got landed official git repo yet. Please work with upstream on reviewing/merging the change and then we'll get it to Arch package as well.
Comment by Cesar Alcalde (noalwin) - Monday, 25 March 2019, 20:46 GMT
This is the same issue that FS#57638

Debian also had this issue and their patch has worked for me to boot Syslinux's HDT.
Debian bug: https://bugs.debian.org/918915
Debian patch: https://sources.debian.org/patches/syslinux/3:6.04~git20190206.bf6db5b4+dfsg1-1/0018-prevent-pow-optimization.patch/
Comment by Anatol Pomozov (anatolik) - Wednesday, 03 April 2019, 18:42 GMT
Thank you for the pointer to the debian patch. I brought it to Arch repo and syslinux-6.04.pre2.r11.gbf6db5b4-1 is available in [testing] now. Could you please verify if it works correctly?
Comment by Cesar Alcalde (noalwin) - Wednesday, 03 April 2019, 21:29 GMT
The HDT seems to work correctly in the testing package.
Comment by Andrew Shark (ashark) - Friday, 19 April 2019, 12:28 GMT
efi64 variant still fails. When booting hdt.c32 I get this:
Undef symbol FAIL: pow
Failed to load libgpl.c32
Failed to load COM32 file hdt.c32
Comment by Marek Howard (marekhwd) - Wednesday, 04 September 2019, 23:34 GMT Comment by Matthias Lisin (matthias.lisin) - Sunday, 24 November 2019, 18:21 GMT
Sorry for letting this slide. I have used this recently and it definitly works now.
Requesting closure.

Loading...