Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#59764 - [kodi] High CPU usage after upgrading glibc and lib32-glibc from 2.26 to 2.28

Attached to Project: Community Packages
Opened by V.I.S. (BytEvil) - Thursday, 23 August 2018, 06:18 GMT
Last edited by Ike Devolder (BlackEagle) - Sunday, 31 March 2019, 11:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Details
Description:
When starting Kodi (v.18, Leia), the process /usr/lib/kodi/kodi-x11 consumes from 5-10% to 100% of CPU cores randomly according to htop. This happens after upgrading glibc and lib32-glibc from v.2.26 to 2.28, because min. version of glibc is 2.28 for compiling latest Kodi version from git.
Kodi (v.17, Krypton) compiled with glibc 2.26 use 5-20% of CPU and this is normal.
Kodi (v.17, Krypton) compiled with glibc 2.28 = high CPU usage.
This happens after upgrading glibc and lib32-glibc from v.2.26 to 2.28

Steps to reproduce:
Install kodi 17.6-8 and running with installed glibc, lib32-glibc v2.26. and see CPU load, then upgrade glibc, lib32-glibc to v.2.28 and see CPU load.


Additional info:
kernel 4.14.66-1 LTS
nvidia 396.51-1

This task depends upon

Closed by  Ike Devolder (BlackEagle)
Sunday, 31 March 2019, 11:46 GMT
Reason for closing:  None
Additional comments about closing:  no longer relevant

Loading...