Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58676 - [egl-wayland, nvidia-utils, nvidia-390xx-utils] File conflicts

Attached to Project: Arch Linux
Opened by Darek (blablo) - Sunday, 20 May 2018, 20:06 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 06 June 2018, 20:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Jan Alexander Steffens (heftig)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
https://github.com/NVIDIA/egl-wayland/pull/10

Please delete libnvidia-egl-wayland * from the nvidia-utils package

Please add 10_nvidia_wayland.json to the egl-wayland package
egl-wayland is the right place for this file

# The NVIDIA EGL driver uses a JSON-based loader to load all EGL External platforms available on the system.
# If this library is not installed as part of a NVIDIA driver installation, a JSON configuration file must be
# manually added in order to make the library work with the NVIDIA driver.

Additional info:
* package version(s)
nvidia-utils 396.24-1
nvidia-390xx-utils 390.59-1
egl-wayland 0+23-1
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 06 June 2018, 20:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  nvidia-utils 396.24-2
nvidia-390xx-utils 390.59-2
egl-wayland 0+23-2
Comment by Jan Alexander Steffens (heftig) - Monday, 21 May 2018, 14:47 GMT
egl-wayland side is fixed; nvidia maintainer needs to decide if they want a dep or a conflict.
Comment by Darek (blablo) - Monday, 21 May 2018, 14:54 GMT
>egl-wayland side is fixed
pull#10 is only information for you that the patch has been sent
Comment by loqs (loqs) - Monday, 21 May 2018, 15:42 GMT Comment by Darek (blablo) - Monday, 21 May 2018, 20:04 GMT
@logs oops, I did not see that. Thanks
@Jan merged pull#10
Comment by loqs (loqs) - Monday, 21 May 2018, 21:04 GMT
pacman -Fo usr/lib/libnvidia-egl-wayland.so
usr/lib/libnvidia-egl-wayland.so is owned by extra/egl-wayland 0+23-2
usr/lib/libnvidia-egl-wayland.so is owned by extra/nvidia-390xx-utils 390.59-1
usr/lib/libnvidia-egl-wayland.so is owned by extra/nvidia-utils 396.24-1
Which prevents nvidia-utils 396.24-1 or nvidia-390xx-utils 390.59-1 from being installed at the same time as xorg-server 1.20.0-3 or 1.20.0-4
as hetfig noted package alterations to the two above mentioned nvidia packages are now required.
Comment by Jan Alexander Steffens (heftig) - Monday, 21 May 2018, 21:17 GMT
xorg-server does not depend on egl-wayland. It's just a makedep.
Comment by Darek (blablo) - Monday, 21 May 2018, 21:59 GMT
Arch Linux use libglvnd and nvidia-settings. Why not add egl-wayland (as optdepends for nvidia-utils/390)?

Explanation:
NVIDIA-Linux-<ARCH>-<VERSION>.run provides the following components
libglvnd -> libglvnd 1.0.0-1
nvidia-settings -> nvidia-settings 396.24-1 (see  FS#58678 )
egl-wayland -> egl-wayland 0+23-2/ nvidia-utils ??????
nvidia-xconfig -> nvidia-utils
nvidia-persistenced -> nvidia-utils
nvidia-modprobe -> nvidia-utils
nvidia-installer -> nvidia-utils
NVIDIA blob -> nvidia-utils

Edit:
It is also possible to do something like that [1]
Nvidia user will need to install only a 'nvidia' package (kernel module) + nvidia-drivers (NV blob) + libglvnd and if needed nvidia-utils package (optional)

Steam will require lib32-nvidia-driver + lib32-libglvnd
Everything has been tested by me

[1] https://github.com/fafryd1125/PKGBUILDs/blob/master/PKGTREE.md
Comment by kyak (kyak) - Tuesday, 05 June 2018, 14:48 GMT
>xorg-server does not depend on egl-wayland. It's just a makedep.

Well, if a user builds xorg-server himself and has nvidia-utils installed, this becomes a problem (exactly my case).
I can't build xorg-server due to missing makedep (egl-wayland) and I can't install egl-wayland due to the conflict with nvidia-utils.

Loading...