Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58660 - [nvidia-340xx] Xorg server won't start with 340.106-35

Attached to Project: Arch Linux
Opened by Grzegorz Antoniak (antekone) - Saturday, 19 May 2018, 08:07 GMT
Last edited by Giancarlo Razzolini (grazzolini) - Saturday, 16 June 2018, 03:34 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Giancarlo Razzolini (grazzolini)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 35
Private No

Details

Description:

xorg-server-1.20.0-2 doesn't start when nvidia-340xx-340.106-35 is installed, and there is no newer nvidia-340xx package available. The only way is to downgrade xorg-server to 1.19.6-2.

Steps to reproduce:
1. Install xorg-server-1.20.0-2,
2. Install nvidia-340xx-340.106-35,
3. Observe that startup scripts enter infinite loop when trying to bring up X,
4. Reboot under 'single' mode
5. Observe error message in Xorg.log related to incompatibility of nvidia driver with this Xorg version.

Steps to fix:
1. Downgrade xorg-server to previous last version (1.19.6-2).
This task depends upon

Closed by  Giancarlo Razzolini (grazzolini)
Saturday, 16 June 2018, 03:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  304.170 fixes this issue.
Comment by Genues (Genues) - Saturday, 19 May 2018, 08:38 GMT
Comment by Nicolas Vila (nicolasv) - Saturday, 19 May 2018, 12:59 GMT
I confirm this. Two computers were affected and also using nvidia-340xx driver
Same workaround: downgrade to 1.19.xxx
Here is below the Xorg log output (adding ignoreABI option to Xorg configuration just makes the system hang, bad idea)

[ ... ]
[ 20.298] (II) LoadModule: "glx"
[ 20.298] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[ 20.340] (II) Module glx: vendor="NVIDIA Corporation"
[ 20.340] compiled for 4.0.2, module version = 1.0.0
[ 20.340] Module class: X.Org Server Extension
[ 20.340] (II) NVIDIA GLX Module 340.106 Tue Jan 9 14:21:56 PST 2018
[ 20.340] (II) LoadModule: "nvidia"
[ 20.341] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 20.342] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 20.342] compiled for 4.0.2, module version = 1.0.0
[ 20.342] Module class: X.Org Video Driver
[ 20.342] ================ WARNING WARNING WARNING WARNING ================
[ 20.343] This server has a video driver ABI version of 24.0 that this
driver does not officially support. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[ 20.343] =================================================================
[ 20.343] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[ 20.343] (II) UnloadModule: "nvidia"
[ 20.343] (II) Unloading nvidia
[ 20.343] (EE) Failed to load module "nvidia" (unknown error, 0)
[ 20.343] (EE) No drivers available.
[ 20.343] (EE)
Fatal server error:
[ 20.343] (EE) no screens found(EE)
[ 20.344] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 20.344] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 20.344] (EE)
[ 20.344] (EE) Server terminated with error (1). Closing log file.
Comment by Darek (blablo) - Saturday, 19 May 2018, 13:09 GMT Comment by Nicolas Vila (nicolasv) - Saturday, 19 May 2018, 17:16 GMT
I also had the same issue on ArchLinuxARM with my Odroid XU4 board today.
The ARMSoc driver is also expecting ABI version 23 and the new Xorg is shipped with version 24.
Althrough this is a ARMSoc issue in this case, I think this xorg upgrade is likely to cause troubles with high number of video drivers.
Comment by YP (knedlyk) - Saturday, 19 May 2018, 20:30 GMT
There is a simple workaround to avoid ABI checking. Just create a file /etc/X11/xorg.conf.d/20-flags.conf with the following:

Section "ServerFlags"
Option "IgnoreABI" "1"
EndSection

Nevertheless it doesn't solve the issue with incompatible nvidia drivers and xorg.
Comment by Elvis (darklyner) - Saturday, 19 May 2018, 21:17 GMT
Hello, I just installed Antergos in its most recent version (antergos-18.5-x86_64), along with its graphics drivers and I find this error just ..
Is there any way I can solve it?
Postdata: Before the last update my system started excellent
Comment by Alexandre Ferreira (alex1a) - Sunday, 20 May 2018, 16:03 GMT
Same here, after yesterday upgrade (sudo pacman -Syu) i can't boot.

After `[ OK ] Reached Target Graphical Interface`, lightdm don't start and prompt keeps blinking

* Linux Version: 4.16.9-1-ARCH
* Desktop Env: xfce
* Display Manager: lightdm
* Nvidia drivers: nvidia-340xx, nvidia-340xx-utils, lib32-nvidia-340xx-utils
* /var/log/lightdm/lightdm.log: https://gist.github.com/alex1a/3c6d4642bb034625622bb027462208ec
* /etc/lightdm/lightdm.conf: https://gist.github.com/alex1a/7dff854f1060b04d7ba6613e795a2b02
* `journalctl -b --unit lightdm.service`: https://gist.github.com/alex1a/a5e3e67a6e4eae629acb80d07313a7f7
* /etc/X11/xorg.conf: https://gist.github.com/alex1a/653b029dc4f1f008ef9d48d25c7b0a55
* `lspci | grep VGA`: `NVIDIA Corporation GF104 [GeForce GTX 460] (rev a1)`
* /var/log/Xorg.0.log: https://gist.github.com/1bb0ab3a68c9649c7d88f674611a2619
* ~/.xinitrc: https://gist.github.com/alex1a/4fad6d7beaa475e41ebecf99b7290b3d
Comment by Giancarlo Razzolini (grazzolini) - Sunday, 20 May 2018, 23:34 GMT
I only now was able to test on my hardware that is nvidia-340xx and I can confirm this is happening. The IgnoreABI seems to work for now. It seems that upstream needs to release a new driver version, and from that dev post, we don't even have a time frame for this.
Comment by CS (Col_Sanders) - Monday, 21 May 2018, 01:45 GMT
I can confirm this on a system using a GeForce 8400GS and nvidia-340xx. With the upgrade to xorg-server-1.20, boot hangs at target Graphical Interface. This occurs with both LXDM and SDDM. Xorg.log contains the WARNING WARNING WARNING WARNING section posted above by nicolasv. In this state a different tty can be reached, though focus keeps returning to tty1 every few seconds as the display manager keeps trying to load. This behavior continues until the display manager is disabled, at which point focus will remain with the other tty and manual console activity can proceed.

However, a word of caution regarding IgnoreABI; be prepared with an install cd or other login method for the possibility of an (apparently) unresponsive system, or disable the display manager service and start manually. I implemented using the configuration file as described by YP. Boot progressed beyond the text message about reaching target graphical interface, but only to a black screen. I was not able to access any other tty. I was able to escape this by logging in via ssh from another machine and deactivating the IgnoreABI .conf file, at which point the black screen reverted to the boot messages ending with Graphical Interface and other ttys could again be accessed. I assume this means the driver loaded but was not properly interfacing with the new ABI, though I have not tried to debug further. For now am simply reverting to 1.19.
Comment by Mickail (TehnoMag) - Monday, 21 May 2018, 08:20 GMT
Confirmed on system with GeForce 8400GS. IgnoreABI not working for me (Black screen and system halt). Only downgrade xorg-server to 1.19 will do the trick
Comment by Nicolas Vila (nicolasv) - Monday, 21 May 2018, 11:14 GMT
Hi Guys.
I confirm that IgnoreABI is freezing my computer with black screen, with no way to switch to a TTY. I have a Geforce GTX 430.

Here is a small tutorial to revert to 1.19 version:

1) Download and unzip one of the files at this page (.tar.gz or .tar.xz)
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/xorg-server&id=d12bc9dda2ac15052c74b51eca1199a3b3a37693
2) unzip the archive on your computer
3) go to unzipped folder: packages-d12bc9dda2ac15052c74b51eca1199a3b3a37693/trunk
4) sudo makepkg -si
5) Once you have downgraded to 1.19.xxx version of xserver-xorg, simply add this to your /etc/pacman.conf in order to avoid further upgrades

IgnorePkg = xorg-server xorg-server-common xorg-server-devel xorg-server-xdmx xorg-server-xephyr xorg-server-xnest xorg-server-xvfb xorg-server-xwayland
Comment by Giancarlo Razzolini (grazzolini) - Monday, 21 May 2018, 12:06 GMT
I don't think you need to go through all these steps to downgrade xorg. You can simply downgrade from your pacman cache or try to download the previous version from of arch linux archive. I downgraded in that way and it is working.
Comment by Pawel (Manonfire) - Tuesday, 22 May 2018, 07:25 GMT
Confirm. The same problem with 340.106-35 on Nvidia Quadro NVS 160M.
@grazzolini is right. "Downgrade" or "downgrader" from AUR is easy downgrading packages 1.20 to 1.19.
Comment by Nicolas Vila (nicolasv) - Tuesday, 22 May 2018, 11:18 GMT
Like Darek noticed on a Nvidia forum:
_ any hope of a 340.xxx release with xorg 1.20 support?
_ Yes, we'll get one out eventually. I just can't promise a particular timeframe. One thing to note is that driver support for the multi-vendor dispatch interface in the new server wasn't quite ready, so these drivers still require replacing the server's libglx.so with ours. Support for loading our glx extension into the server's new glvnd interface is being worked on and should show up in a future release, but it's unlikely that we'll backport it to the legacy branches.
Aaron Plattner (NVIDIA Linux Graphics)
Comment by damien (damien200) - Saturday, 02 June 2018, 10:01 GMT
Same problem with a GTS360M, thanks for the workaround
Comment by Stephen Cox (stephencox) - Wednesday, 06 June 2018, 19:32 GMT
340.107 is released to address this
Comment by Giancarlo Razzolini (grazzolini) - Wednesday, 06 June 2018, 19:41 GMT Comment by Mickail (TehnoMag) - Thursday, 07 June 2018, 06:42 GMT
Comment by Pedro Fayolle (pilaf) - Sunday, 10 June 2018, 21:31 GMT
Comment by Giancarlo Razzolini (grazzolini) - Thursday, 14 June 2018, 21:38 GMT
The packages have been rebuilt and are on [extra] now. This was done because of  FS#58942 . Please, report back, this issue should be fixed with this driver version release.
Comment by Serede (Serede) - Thursday, 14 June 2018, 21:55 GMT
Even with the 340.107 drivers I am getting the behavior mentioned here:
https://bbs.archlinux.org/viewtopic.php?id=237338
Basically, optirun works correctly with the NVIDIA card, but Intel Graphics provide no acceleration whatsoever since the GLX extension is completely broken.
Comment by Giancarlo Razzolini (grazzolini) - Friday, 15 June 2018, 02:21 GMT
Hi @Serede. Have you installed libglvnd before installing nvidia-340xx? I have a standalone card, so I can't test bumblebee. I didn't even knew there were optimus cards running 340xx. But the 340.107 driver fixed the issue with xorg 1.20 for me.
Comment by Serede (Serede) - Friday, 15 June 2018, 10:24 GMT
@grazzolini Yes I did. It bothers me because with other versions of the driver (upstream and 390xx) everything works fine, but as soon as I install 340xx Intel Graphics break.
Comment by Ralph Corderoy (RalphCorderoy) - Friday, 15 June 2018, 11:49 GMT
Problem has gone with xorg-server 1.20.0-7 and nvidia-340xx 340.107-3 on
`NVIDIA Corporation GT218 [ION] [10de:0a64] (rev a2)'.
Thanks for your efforts.
Comment by damien (damien200) - Friday, 15 June 2018, 11:54 GMT
Problem solved for me (GTS360M) Thanks !
Comment by Elvis (darklyner) - Friday, 15 June 2018, 12:35 GMT
Muchas gracias. Problema resuelto (GeForce 9800 GT)
Comment by Edmund Lodewijks (lquidfire) - Friday, 15 June 2018, 13:51 GMT
Problem solved for me (NVIDIA Corporation GT218 [GeForce 210]). Cheers!
Comment by Giancarlo Razzolini (grazzolini) - Saturday, 16 June 2018, 03:33 GMT
@Serede, it looks like your issue is not related to this one. I'm closing this for now. Please, feel free to open another bug, with more detail.

Loading...