Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58280 - [cmark-gfm] conflicts with community/cmark package

Attached to Project: Community Packages
Opened by cvp (cvp) - Thursday, 19 April 2018, 20:51 GMT
Last edited by Felix Yan (felixonmars) - Sunday, 26 August 2018, 14:12 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

The cmark and cmark-gfm packages have the following file conflicts:
/usr/include/cmark.h
/usr/include/cmark_export.h
/usr/include/cmark_version.h

The rest of the files in cmark-gfm are named to avoid name collisions with the cmark package,
e.g. the executable "cmark-gfm" vs "cmark", the library "libcmark-gfm.so" vs "libcmark.so", etc.,
so presumably it's meant to be possible to have both installed.
And cmark-gfm of course does not suffice as a replacement for cmark.


Additional info:

Versions:
community/cmark 0.28.3-1
community/cmark-gfm 0.28.0.gfm.11-1


Steps to reproduce:

Attempt to install both community/cmark and community/cmark-gfm:
$ pacman -S cmark cmark-gfm
[...]
error: failed to commit transaction (conflicting files)
/usr/include/cmark.h exists in both 'cmark' and 'cmark-gfm'
/usr/include/cmark_export.h exists in both 'cmark' and 'cmark-gfm'
/usr/include/cmark_version.h exists in both 'cmark' and 'cmark-gfm'
Errors occurred, no packages were upgraded.
This task depends upon

Closed by  Felix Yan (felixonmars)
Sunday, 26 August 2018, 14:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  cmark-gfm 0.28.3.gfm.15-1
Comment by Eli Schwartz (eschwartz) - Wednesday, 25 April 2018, 17:52 GMT
Please file an upstream bug, there is a reason they renamed the binaries in the upstream code, and they should install headers to a private subdirectory for the same reason (and instruct the pkg-config file to tell people to look there).

Oh, also there is something funky going on with their pkgconfig file, since the gfm version has libdir=/usr/usr/lib
Comment by FichteFoll (FichteFoll) - Monday, 20 August 2018, 15:56 GMT Comment by Johannes Wienke (languitar) - Tuesday, 21 August 2018, 08:35 GMT
0.28.3.gfm.15 got released and should fix the issue as far as I can tell.

Loading...