Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57564 - [xf86-video-nouveau] DRI3 suddenly stopped turning on at some point in the past 3 months

Attached to Project: Arch Linux
Opened by Jimi Bove (Jimi-James) - Sunday, 18 February 2018, 21:12 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 11 December 2019, 12:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Lukas Fleischer (lfleischer)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

(The attached files are from when I was on kernel version 4.9.78-1-lts, but I've confirmed that this bug persists on non-LTS 4.12.12 as well as 4.14.17-1-lts.)

I have two GPUs a GT 740 on nouveau, and an AMD R9 Fury on amdgpu. Both cards are working fine, and both drivers seem to be working fine, other than this issue.

Problem:
DRI3 won't activate, despite no logs that I know of ever spitting out an error message related to it, and despite nothing about my system changing since it last worked other than package versions. I'm not sure exactly when this problem started, because I haven't been playing video games on Linux as often lately (DRI_PRIME is what I need DRI3 for), but it most likely started within the last 3 months.

Steps to reproduce:
I have no idea. This is why I'm stumped. The Xorg conf files are exactly what they should be and exactly what they were the last time this worked. Here are the packages I've tried downgrading to versions that I had when this worked, even all at the same time just in case:
-linux{,-lts}
-xorg-server{,-common,-devel}
-xf86-input-libinput & libinput
-{,lib32-}mesa
-mesa-vdpau
-xf86-video-{nouveau,amdgpu}

I first noticed this problem over 2 weeks ago, but have spent all this time trying to figure out how to reproduce it before doing a bug report, even getting help from #nouveau (and trying to get help from #xorg-users and #xorg-devel, but the former was empty and the latter ignored me). I give up. I can't figure out how to reproduce it unless there are even more packages I can try downgrading that I haven't heard of, but I badly need this fixed.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 11 December 2019, 12:28 GMT
Reason for closing:  Upstream
Comment by Andreas Radke (AndyRTR) - Tuesday, 20 February 2018, 18:11 GMT
You probaby get the best support and contact to upstream devs at nouveau irc channel.
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 12:58 GMT
Upstream report?
Comment by Jimi Bove (Jimi-James) - Wednesday, 21 March 2018, 16:43 GMT
Well, as far as IRC goes, nobody ever responds besides two users who aren't nouveau devs and have already done what they could to help me troubleshoot. And I've been waiting until I know more about the cause behind this to submit an upstream bug report, since right now it's completely unknown. On the bright side, the other day on reddit I found someone else with the same problem, so we can at least start ruling stuff out. This other person has a GT 730, while I have a GT 740, so it's most likely at this point to be something wrong with NVidia's 700 series.

What I just can't wrap my head around is how this started happening. Is there any way to get a complete, absolute, 100% list of every last package that has anything to do with this issue? Because the fact that I've already downgraded every one I know of to a version before this issue started happening, and still have this problem, really makes me question cause and effect and my own sanity.
Comment by Jimi Bove (Jimi-James) - Friday, 06 April 2018, 22:03 GMT
Reported upstream after the other person with this issue confirmed that switching their card to AMD fixed it: https://bugs.freedesktop.org/show_bug.cgi?id=105935
Comment by Darek (blablo) - Monday, 30 April 2018, 07:28 GMT
This [1] patch prevents random xserver freezes
tested:
GPU GTX 550Ti
mesa 18.1.0rc2
xorg-server 1.19.99.905
xf86-video-nouveau-git 1.0.15.r5.gac8f7b9
DRI3 enabled

I noted the same behavior with:
mesa 18.0.1-1
xorg-server 1.19.6+13+gd0d1a694f-2
xf86-video-nouveau-git 1.0.15.r5.gac8f7b9
DRI3 enabled

[1] https://patchwork.freedesktop.org/series/41258/ (rev 4)

I'm not sure if it is related, but it's worth mentioning
Comment by Andreas Radke (AndyRTR) - Wednesday, 11 December 2019, 12:28 GMT

Loading...