FS#57400 - [plasma-wayland-session] Login freezes only mouse works

Attached to Project: Arch Linux
Opened by rainer (raneon) - Tuesday, 06 February 2018, 19:59 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 06 February 2018, 20:56 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After the upgrade to Plasma 5.12 from testing I cannot login to Plasma-Wayland anymore. After typing the password and pressing enter, SDDM's display content will more or less freeze, I can still move the mouse, but I cannot go to another TTY (SSH works), rebooting is possible with Ctrl + Alt + Del. I have this issue only with my AMD GPU (DC is enabled), Intel works fine. The strange thing is that Plasma 5.12 beta worked well on Wayland. I tried to find something helpful in the logs, but so far I had to luck.

Additional info:
* Plasma 5.12 from testing

Steps to reproduce:
1. Login to Plasma-Wayland with SDDM
2. The screen freezes, only mouse movements are possible
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 06 February 2018, 20:56 GMT
Reason for closing:  Not a bug
Comment by rainer (raneon) - Tuesday, 06 February 2018, 20:24 GMT
Please close the bug, after further testing this is related to DC on linux-git, on linux 4.15 from testing it works well.