Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56866 - [linux] CPU frequncy freezing

Attached to Project: Arch Linux
Opened by Daniel Bershatsky (daskol) - Tuesday, 26 December 2017, 08:50 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 29 January 2018, 15:21 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On my Dell Latitude E7470 laptop CPU frequency scaling exhibits weird behavior. If AC adapter is plugged in then everything is okay. But if one switch to battery the CPU frequency squeeze on 400MHz and this value could not change neither with cpupower nor sysfs. I have check this issue with intel_pstate module as well as acpi-cpufreq. In the case of acpi-cpufreq CPU frequncy scaling is completly broken since cpupower shows actual frequency 2.8GHz while i7z says that frequency is about 400MHz.

Well, Intel Core i7 works as Pentium III.


Additional info:
* kernl 4.14.8-1-ARCH
* intel-ucode 20171117-1
* linux-firmware 20171206.fdee922-1


Steps to reproduce:
* plugin in AC adapter
* look at frequency in output of i7z
* remove AC adapter
* look at frequency in output of i7z
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 29 January 2018, 15:21 GMT
Reason for closing:  Upstream
Comment by Doug Newgard (Scimmia) - Wednesday, 27 December 2017, 18:39 GMT
Is anything happening at the time? 400MHz is pretty normal for idle.
Comment by Daniel Bershatsky (daskol) - Thursday, 28 December 2017, 08:40 GMT
Absolutely nothing even one tries to change governor or minimum frequency via sysfs or cpupower. Moreover if one runs stress test then CPU frequency is all the same.
Comment by Emantor (Emantor) - Friday, 05 January 2018, 08:18 GMT
Did you install the latest BIOS Update (1.18.5)? I'm experiencing the same problem on my Latitude E7270 as well, but only after I did the BIOS update yesterday.
Comment by Emantor (Emantor) - Friday, 05 January 2018, 08:30 GMT
Fixed it:
1. shutdown your laptop
2. remove back cover
3. unplug battery
4. hold power button for 20s (I counted to 40 to be sure)
5. replug battery
6. attach back cover
7. start laptop and retest

Loading...