Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#55667 - [wine] winecfg crashes on startup with freetype 2.8.1

Attached to Project: Community Packages
Opened by kinodont (kinodont) - Monday, 18 September 2017, 07:23 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 30 September 2017, 12:20 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Additional info:
freetype2 2.8.1-1
wine 2.17-1


Steps to reproduce:
1. have a clean 64-bit Wine prefix
2. $ winecfg
3. message similar to these appear:
wine: Unhandled page fault on read access to 0x00000008 at address 0x7f31d2449c0f (thread 0030), starting debugger...
winedbg: Internal crash at 0x7f8bb1159c0f

More information is available in the upstream bug report.


So far, I've reported it as a Wine bug here: https://bugs.winehq.org/show_bug.cgi?id=43715
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 30 September 2017, 12:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  wine 2.18-1
Comment by Laurent Carlier (lordheavy) - Sunday, 24 September 2017, 11:18 GMT Comment by Eli Schwartz (eschwartz) - Sunday, 24 September 2017, 18:08 GMT
There is a patch attached to https://bugs.winehq.org/show_bug.cgi?id=43715 which is reported to fix things.
Comment by Laurent Carlier (lordheavy) - Sunday, 24 September 2017, 18:52 GMT
It fixes the crash, but you can't build wine because of wine  bug 43716  (also related to freetype upgrade)
Comment by Xier (xier) - Wednesday, 27 September 2017, 12:01 GMT
Can't build because of Error: Cannot open face ../../wine-git/fonts/courier.ttf

https://bugs.winehq.org/show_bug.cgi?id=43716
Comment by Masato Hashimoto (hashimo) - Thursday, 28 September 2017, 10:55 GMT
Build error has been fixed on upstream.
Comment by Alexander W. Ahjolinna (ahjolinna) - Thursday, 28 September 2017, 16:14 GMT
I could build wine-git just fine, but wine-staging-git failed for me with the same old error
Comment by Daniel Bermond (Bermond) - Thursday, 28 September 2017, 16:29 GMT
@ahjolinna
This is normal and expected.
That's because wine-staging-git needs an upstream rebase commit to catch the changes from the wine git repository.
And in many times, this happens only near to the next release.

If you take a look at the wine-staging git repository, you'll see that currently the last upstream commit is the 2.17 release one.
So, no rebase commits yet at the time of this writing.

Loading...