Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53975 - [pitivi] Missing deps (gstgtk)

Attached to Project: Community Packages
Opened by Nicolas Repentin (ouafnico) - Monday, 08 May 2017, 18:41 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 06 July 2017, 09:18 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Pitivi can't be launched. Dependancy missing

ERREUR - Les dépendances requises suivantes sont manquantes :
=============================================================
- gstgtk not found on the system
Dépendances suggérées manquantes
- pycanberra not found on the system
-> active les notifications sonores lorsque le rendu est terminé


Additional info:
* pitivi 0.98-2
* system is uptodate


Steps to reproduce:
Install pitivi with pacman.
Start pitivi on a terminal.

Maybe it's not a bug, or more a gst bug.
Following this old bug, it was a gst problem, but actually the problem is present again.

https://bugs.archlinux.org/task/50271
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 06 July 2017, 09:18 GMT
Reason for closing:  Fixed
Comment by Massimo Branchini (max.bra) - Tuesday, 09 May 2017, 06:23 GMT
confirmed:

ERROR - The following hard dependencies are unmet:
==================================================
- gstgtk not found on the system
Missing soft dependency:
- pycanberra not found on the system
-> abilita le notifiche sonore quando il rendering è completo

% pacman -Qs gst-plugins
local/gst-plugins-bad 1.12.0-1
local/gst-plugins-base 1.12.0-1
local/gst-plugins-base-libs 1.12.0-1
local/gst-plugins-good 1.12.0-1
local/gst-plugins-ugly 1.12.0-1
local/lib32-gst-plugins-base-libs 1.8.3-1
Comment by Doug Newgard (Scimmia) - Tuesday, 09 May 2017, 15:15 GMT
Definitely a pitivi problem. gstgtk module was renamed, pitivi doens't know that in the current stable version.

https://git.gnome.org/browse/pitivi/commit/?id=99e59bea86b46f75321c449e5fb825e82af78cf1
Comment by Davi da Silva Böger (dsboger) - Sunday, 14 May 2017, 21:28 GMT
I reported the issue upstream, asking for a point release: https://phabricator.freedesktop.org/T7757
Comment by Stefan Husmann (stefanhusmann) - Thursday, 25 May 2017, 21:04 GMT
Upstream's answer makes me think that there will not be a fix in the stable version soonish.
Comment by Bart (sleeping) - Friday, 16 June 2017, 19:29 GMT
Can Pitivi be patched for a quick fix?
Comment by Johannes Maibaum (jmx) - Saturday, 17 June 2017, 10:33 GMT
The following prepare() function quick-fixes pitvi 0.98-2 easily:

prepare() {
cd "$pkgname-$pkgver"

# Dependency "gstgtk" was renamed to "gtk" as per gstreamer 1.12, see:
# https://git.gnome.org/browse/pitivi/commit/?id=99e59bea86b46f75321c449e5fb825e82af78cf1
# This fixes  FS#53975  - [pitivi] Missing deps (gstgtk)
sed -i 's/gstgtk/gtk/' pitivi/check.py
}
Comment by Alexandru Băluț (aleb) - Friday, 30 June 2017, 22:40 GMT
The 0.98.1 release has the necessary fixes so Pitivi works with GStreamer 1.12, sorry for the delay.
Comment by Sergej Pupykin (sergej) - Saturday, 01 July 2017, 15:05 GMT
pitivi-0.98.1-1 uploaded to community
Comment by Johannes Maibaum (jmx) - Wednesday, 05 July 2017, 20:34 GMT
It works for me, thank you!

Loading...