Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#5324 - Locale not set before mounting filesystems

Attached to Project: Arch Linux
Opened by Philip Nilsson (leffe) - Thursday, 31 August 2006, 16:55 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 25 October 2007, 06:23 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


(I don't think it's set at all during init.)

Some filesystem drivers need to know the system's locale to mount correctly, the Linux-NTFS driver is one such case. The workaround is to set locale=_ in the fstab, however, that is quite the hack.

In case setting the locale could interfere with system script (sorting, etc.), I suggest only setting it for mounting commands.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 25 October 2007, 06:23 GMT
Reason for closing:  Won't implement
Comment by Judd Vinet (judd) - Friday, 01 September 2006, 18:10 GMT
Got a patch?
Comment by Philip Nilsson (leffe) - Friday, 01 September 2006, 19:53 GMT
Two patches, one for local filesystems in rc.sysinit and one for other filesystems in rc.d/netfs.

I didn't set the locale for the root filesystem, I do not know of any popular root filesystem that checks for the locale environment variables in its mounter.

The virtual filesystems don't care either.
Comment by Roman Kyrylych (Romashka) - Monday, 04 September 2006, 10:22 GMT
What if I want to mount my filesystem with different locale than my system's default? If I add locale=something to fstab will it take precedence?
Comment by Philip Nilsson (leffe) - Monday, 04 September 2006, 17:54 GMT
The locale appears to be overridden if you set it in the mount options. At least for ntfsprogs, but the general way of programming is to override environment variables by specific options, I assume that is the case everywhere.
Comment by Thomas Bächler (brain0) - Monday, 06 November 2006, 21:33 GMT
IMO, this is not a bug. A filesystem shouldn't depend on the locale that is set on mount time. Only non-*nix filesystems care about this, and for those you should set the locale= option. All *nix filesystems use the locale that is set when accessing the filesystem.
Comment by Peter Galiovsky (galiyosha) - Sunday, 03 June 2007, 11:41 GMT
This affects some daemons as well, for example ivman. I'm using a UTF-8 locale. When ivman is started during system init, it runs in a POSIX locale. When it then calls pmount, it does not mount volumes using iocharset=utf-8, which results in garbled national characters all over the volumes...
Comment by Tobias Powalowski (tpowa) - Saturday, 06 October 2007, 13:06 GMT
i think this is a configuration issue and not a arch issue