Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#53069 - [nvidia-340xx-utils] 340.102-5 fails to build mpv-git

Attached to Project: Arch Linux
Opened by helle vaanzinn (glitsj16) - Thursday, 23 February 2017, 20:49 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 02 March 2017, 20:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Building mpv-git from AUR recently throws an error about ld not able to find -lEGL & -lGL. Downgrading nvidia-340xx-utils to 340.102.1 works just fine. Several changes have happenend recently with the nvidia-340xx-utils packaging, can't really tell what's causing this.

Attaching mpv-git makepkg logs for both nvidia-340xx-utils versions 340.102-1 & 340.102-5.

Regards.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 02 March 2017, 20:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in [testing]
Comment by Darek (blablo) - Friday, 24 February 2017, 06:19 GMT
Missing 'usr/bin/ldconfig -r .' in nvidia-340xx-utils.install/304 (lib32 also)
Comment by Jan de Groot (JGC) - Friday, 24 February 2017, 09:52 GMT
It's not about a missing ldconfig line or something like that.

The current package is completely unsuitable for compiling. The development symlinks are in /usr/lib/nvidia while mesa that contains the .pc files doesn't specify the linker path, so gcc/ld will never find the libraries.

Comment by Laurent Carlier (lordheavy) - Friday, 24 February 2017, 22:24 GMT
you should be able to install mesa/mesa-libgl alongside nvidia-340xx-utils package
Comment by helle vaanzinn (glitsj16) - Friday, 24 February 2017, 22:47 GMT
@Laurent

Thanks, will try and report back as soon as my kernel build is finished. It's a bit confusing though, I always looked at mesa & nvidia as mutually exclusive (Xorg driver-wise).
Comment by helle vaanzinn (glitsj16) - Friday, 24 February 2017, 23:23 GMT
@Laurent

Installed mesa-libgl, but that resulted in exactly the same error when compiling mpv-git. Based on the comment from Jan de Groot and some testing, I have a PKGBUILD for nvidia-340xx-utils 340.102-5 that works just fine for compilation: https://gist.github.com/glitsj16/f053d88d55c5bfa6ee258327200ac730

The PKGBUILD differs with the current official one from extra on 3 points:
(1) re-adds symlinks in /usr/lib to /usr/lib/nvidia as 340.102-1 did;
(2) adds nvidia-utils to provides (which fixes https://bugs.archlinux.org/task/53067?project=1&cat[0]=2&string=nvidia-340xx-utils); and
(3) runs create_links before creating /etc/ld.so.conf.d/00-nvidia.conf (to silence readelf complaining about /etc/ld.so.conf.d not being a regular file).

Thoughts?
Comment by Laurent Carlier (lordheavy) - Monday, 27 February 2017, 12:24 GMT
@helle

(1) it will break multigpu (optimus/bumblebee) system
(2) fixed soon
(3) only a cosmetic change
Comment by helle vaanzinn (glitsj16) - Thursday, 02 March 2017, 10:40 GMT
@Laurent

Finally got things working. After installing nvidia-340xx-utils & mesa (both from testing) things are back to normal. Thanks for your response.

Loading...