Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#52283 - [bzr] not working

Attached to Project: Arch Linux
Opened by Stefan Husmann (stefanhusmann) - Tuesday, 27 December 2016, 22:48 GMT
Last edited by Maxime Gauduin (Alucryd) - Saturday, 04 February 2017, 19:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: bzr is not working anymore.

Additional info:
* package version(s) bzr 2.7.0-1
* config and/or log files etc.

Steps to reproduce:
run plain bzr (or try a bzr-PKGBUILD from AUR):

bzr: ERROR: exceptions.TypeError: first argument must be string or compiled pattern

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/bzrlib/commands.py", line 930, in exception_to_return_code
return the_callable(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/commands.py", line 1121, in run_bzr
ret = run(*run_argv)
File "/usr/lib/python2.7/site-packages/bzrlib/commands.py", line 673, in run_argv_aliases
return self.run(**all_cmd_args)
File "/usr/lib/python2.7/site-packages/bzrlib/commands.py", line 697, in run
return self._operation.run_simple(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/cleanup.py", line 136, in run_simple
self.cleanups, self.func, *args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
result = func(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/builtins.py", line 1507, in run
source_branch=br_from)
File "/usr/lib/python2.7/site-packages/bzrlib/bzrdir.py", line 367, in sprout
create_tree_if_local=create_tree_if_local)
File "/usr/lib/python2.7/site-packages/bzrlib/cleanup.py", line 132, in run
self.cleanups, self.func, self, *args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
result = func(*args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/bzrdir.py", line 417, in _sprout
result_repo.fetch(source_repository, fetch_spec=fetch_spec)
File "/usr/lib/python2.7/site-packages/bzrlib/vf_repository.py", line 1268, in fetch
find_ghosts=find_ghosts, fetch_spec=fetch_spec)
File "/usr/lib/python2.7/site-packages/bzrlib/decorators.py", line 218, in write_locked
result = unbound(self, *args, **kwargs)
File "/usr/lib/python2.7/site-packages/bzrlib/vf_repository.py", line 2585, in fetch
find_ghosts=find_ghosts)
File "/usr/lib/python2.7/site-packages/bzrlib/fetch.py", line 77, in __init__
self.__fetch()
File "/usr/lib/python2.7/site-packages/bzrlib/fetch.py", line 98, in __fetch
pb.update(gettext("Finding revisions"), 0, 2)
File "/usr/lib/python2.7/site-packages/bzrlib/i18n.py", line 40, in gettext
install()
File "/usr/lib/python2.7/site-packages/bzrlib/i18n.py", line 92, in install
_translations = install_translations(lang)
File "/usr/lib/python2.7/site-packages/bzrlib/i18n.py", line 114, in install_translations
fallback=True)
File "/usr/lib/python2.7/gettext.py", line 554, in translation
t = _translations.setdefault(key, class_(fp))
File "/usr/lib/python2.7/gettext.py", line 255, in __init__
self._parse(fp)
File "/usr/lib/python2.7/gettext.py", line 391, in _parse
self.plural = c2py(plural)
File "/usr/lib/python2.7/gettext.py", line 177, in c2py
result, nexttok = _parse(_tokenize(plural))
File "/usr/lib/python2.7/gettext.py", line 114, in _parse
nexttok = next(tokens)
File "/usr/lib/python2.7/gettext.py", line 85, in _tokenize
for mo in re.finditer(_token_pattern, plural):
File "/usr/lib/python2.7/re.py", line 190, in finditer
return _compile(pattern, flags).finditer(string)
File "/usr/lib/python2.7/re.py", line 247, in _compile
raise TypeError, "first argument must be string or compiled pattern"
TypeError: first argument must be string or compiled pattern
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Saturday, 04 February 2017, 19:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.7.0-2
Comment by Stefan Husmann (stefanhusmann) - Thursday, 29 December 2016, 07:35 GMT
With python2 in version 2.7.12 it works again.
Comment by Stefan Husmann (stefanhusmann) - Thursday, 29 December 2016, 15:20 GMT Comment by Stefan Husmann (stefanhusmann) - Thursday, 29 December 2016, 19:42 GMT
Comment by Doug Newgard (Scimmia) - Friday, 30 December 2016, 14:17 GMT
Works fine for me. Looks like it might be related to translations; you might want to post your locale info here and upstream.
Comment by Stefan Husmann (stefanhusmann) - Friday, 30 December 2016, 18:54 GMT
Good idea.

# locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE=C
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
Comment by Daniel (Daniel.alomar) - Sunday, 15 January 2017, 16:36 GMT
Same error here:
# locale
LANG=ca_ES.UTF-8
LC_CTYPE="ca_ES.UTF-8"
LC_NUMERIC="ca_ES.UTF-8"
LC_TIME="ca_ES.UTF-8"
LC_COLLATE=C
LC_MONETARY="ca_ES.UTF-8"
LC_MESSAGES="ca_ES.UTF-8"
LC_PAPER="ca_ES.UTF-8"
LC_NAME="ca_ES.UTF-8"
LC_ADDRESS="ca_ES.UTF-8"
LC_TELEPHONE="ca_ES.UTF-8"
LC_MEASUREMENT="ca_ES.UTF-8"
LC_IDENTIFICATION="ca_ES.UTF-8"
LC_ALL=
Comment by Johan Forberg (jforberg) - Sunday, 15 January 2017, 19:24 GMT
I have the same problem. Here is my information:

locale

LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=en_GB.UTF-8

python2 --version
Python 2.7.13

bzr --version
Bazaar (bzr) 2.7.0

I hope this is useful to you.
Comment by Maxime Gauduin (Alucryd) - Sunday, 15 January 2017, 22:25 GMT
Please stop posting your locale information here, it's been determined already that it's what causing the issue. There have been breaking gettext changes in python 2.7.13 and bzr translations aren't working anymore. Upstream is working on it.
Comment by Stefan Husmann (stefanhusmann) - Tuesday, 17 January 2017, 22:31 GMT
Not sure. They fix a bug coming up in Debian (Ubuntu) with the debianized version 2.7.12-7 of python and claim that this is the same bug here. But it is not, I tested that.
Comment by Stefan Husmann (stefanhusmann) - Wednesday, 18 January 2017, 10:13 GMT
Sorry for double posting.
Comment by Stefan Husmann (stefanhusmann) - Monday, 30 January 2017, 21:31 GMT
Upstream has a working patch in branch for 2.7.1 now.

Loading...