Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51696 - [nvidia] Pacman hook missing

Attached to Project: Arch Linux
Opened by Konstantin Gizdov (kgizdov) - Friday, 04 November 2016, 18:35 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 04 November 2016, 21:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Pacman needs to rebuild initramfs on upgrade. I have to do it manually or my system will not boot on the next reboot. Please add a hook for this.


Additional info:
* package version(s)
nvidia 375.10-2
* config and/or log files etc.
N/A


Steps to reproduce:
Upgrade nvidia
Reboot
GUI is not possible
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 04 November 2016, 21:30 GMT
Reason for closing:  Not a bug
Comment by Darek (blablo) - Friday, 04 November 2016, 19:41 GMT
Comment by Konstantin Gizdov (kgizdov) - Friday, 04 November 2016, 20:20 GMT
I'm sure you'll agree that after upgrade not running mkinitcpio will always be a problem. I also think that nowhere during installation or upgrade is the user notified that they should run mkinitcpio. The only message is 'please reboot' which will have a negative impact if mkinitcpio is not run before. And I'm sure that preference has nothing to do with it as mkinitcpio needs to happen. I understand that the "linux" name must change depending on installed kernels, but that surely can be corrected for. Could users at least get a message on upgrade/install before they break the system?

I also see the possibility of having .conf file somewhere where the user lists the name for which mkinitcpio needs to run or if to run it. Why not have something of the sort?
Comment by Doug Newgard (Scimmia) - Friday, 04 November 2016, 21:29 GMT
The is only a problem if you've customized your mkinitcpio. If you do that, you need a custom hook.

Loading...