Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#51693 - [systemd] 232-1 Failed to create notify socket: Protocol not supported

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Friday, 04 November 2016, 15:25 GMT
Last edited by Dave Reisner (falconindy) - Friday, 04 November 2016, 18:08 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Upgraded my eeePC with Archlinux testing and when I want to start systemd 232-1, boot sequence is blocked

It ends in emergency shell.

I had to boot an USB key with last ISO, chroot on my system to downgrade systemd and fix start process.


Additional info:
systemd232-1

Steps to reproduce:

Just upgrade your archlinux installation with systemd 232.

I added a screenshot of my broken eeePC installation.
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 04 November 2016, 18:08 GMT
Reason for closing:  Upstream
Additional comments about closing:  https://github.com/systemd/systemd/issue s/4575
Comment by Dave Reisner (falconindy) - Friday, 04 November 2016, 16:20 GMT
Your photo clearly says systemd 231, not 232... Could you please rebuild your initramfs and try again? I can't reproduce this error.
Comment by Frederic Bezies (fredbezies) - Friday, 04 November 2016, 16:24 GMT
I reproduced it. Attaching photo. I moved a little, but you can read : "starting version 232".

My eeePC is using archlinux testing, 32 bit.
Comment by Darek (blablo) - Friday, 04 November 2016, 16:26 GMT
I cannot confirm, it seems that everything works

[ 0.745807] systemd[1]: systemd 232 running in system mode. (+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
[ 0.745956] systemd[1]: Detected architecture x86-64.
Comment by Frederic Bezies (fredbezies) - Friday, 04 November 2016, 16:28 GMT
Ouch !

32 bit only bug ? Will try on my Toshiba which is using a 64 bit archlinux + testing install and report.

Edit : Works on my toshiba laptop. So a 32 bit only bug ? I remember I did not made a separate /boot partition when I installed Archlinux on my eeePC. Can it be related to my bug on my eeePC ?

Edit 2 : Works on my main computer too. Also a 64 bit installation. Weird.
Comment by Frederic Bezies (fredbezies) - Friday, 04 November 2016, 17:15 GMT
Reproduced it in a 32bit VirtualBox VM. I wonder if it is also related to a missing separate boot partition.

Will try installing a new VM with separate /boot, / and /home partition. Will report asap.

Edit : still the same bug. Looks like there is a bug with 32 bit installations :(
Comment by Dave Reisner (falconindy) - Friday, 04 November 2016, 18:08 GMT
Let's continue this upstream.

Loading...