Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50706 - [qt5-base] file dialog causes segfault with qgnomeplatform inside wayland session

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Thursday, 08 September 2016, 17:11 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 08 September 2016, 17:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
On gnome-wayland session QT_QPA_PLATFORMTHEME is set to qgnomeplatform. Attempting to use file dialog causes QT5/KDE application to crash.

Additional info:
* package version(s): qt5-base 5.7.0-2
* related file: /usr/lib/qt/plugins/platformthemes/libqgtk3.so
* config and/or log files etc.:
part of dmesg
[ 7034.772408] alive-pc kernel: traps: kwrite[3942] general protection ip:7f802e
c34565 sp:7ffcd94ce110 error:0 in libX11.so.6.3.0[7f802ec15000+13b000]
gdb backtrace attached.

Steps to reproduce:
1. From display manager, select "GNOME on Wayland" session.
2. Launch QT5/KDE application, such as kwrite or QT Designer (/usr/lib/qt/bin/designer).
3. Inside kwrite, goto File -> Open to use file open dialog or just press CTRL+O.
4. kwrite disappeared from sight and segfault notice appeared on kernel log.

Additional note:
This doesn't happen when QT_QPA_PLATFORMTHEME isn't set to qgnomeplatform. qt5ct platform theme works ok.
Only QT5 applications are affected. QT4 application such as okular works fine.

I mark this as high because it has potential to cause loss of data.

This bug hasn't reported to qgnomeplatform author[1]

[1] https://github.com/MartinBriza/QGnomePlatform
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 08 September 2016, 17:21 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#50013 

Loading...