Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50548 - [zenity] build without webkit2gtk

Attached to Project: Arch Linux
Opened by Emil (xexaxo) - Sunday, 28 August 2016, 17:27 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 24 January 2017, 13:08 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

zenity 3.20.0-1 (and earlier versions) depend on webkit2gtk which can be toggled at build time.
It's a bit odd for a "Display graphical dialog boxes from shell scripts" tool to pull a bulky web content engine like webkit2gtk as dependency.

Can we consider rebuilding with "--disable-webkitgtk" and dropping the dependency ?

Fwiw I've been using a 'stripped' version for 6+ months now without any visible side effects.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 24 January 2017, 13:08 GMT
Reason for closing:  Won't implement
Additional comments about closing:  disabling webkit2gtk removes functionality. Upstream builds with webkit2gtk by default, so we leave it that way. You can upload a webkit-free version to AUR if you want.
Comment by Emil (xexaxo) - Thursday, 29 December 2016, 19:00 GMT
It's been 4 months without any input on this. Humble ping anyone ?
Comment by Erik Wesselius (erikwesselius) - Thursday, 19 January 2017, 14:51 GMT
I got this message today after a pacman upgrade

(23/26) upgrading webkitgtk [######################] 100%

> WARNING: WebKitGTK+ 2.4 is known to have many security vulnerabilities that
will NOT be fixed. Avoid browsing with it.

(24/26) upgrading webkitgtk2 [######################] 100%

> WARNING: WebKitGTK+ 2.4 is known to have many security vulnerabilities that
will NOT be fixed. Avoid browsing with it.

The two programs that I use that depend on webkit2gtk are yelp and zenity. It would be great if the dependency could be removed or rebuilsd the package against webkitgtk (3).

Comment by Doug Newgard (Scimmia) - Thursday, 19 January 2017, 14:59 GMT
erikwesselius, please don't post totally irrelevant info here. This is about webkit2, the messages you got were webkit1.
Comment by Emil (xexaxo) - Thursday, 19 January 2017, 15:10 GMT
The warning message is triggered even while installing/updating webkit2gtk. Perhaps it's a package bug, pacman deficiency (cannot handle separate .install for split packages) or other ?
In either case its not Erik's fault - so calling him out is silly.

That aside - has anyone considered my request ? Can attach a patch for the PKGBUILD if people prefer.
Comment by Doug Newgard (Scimmia) - Thursday, 19 January 2017, 15:18 GMT
Please pay attention to package names. The warning is on webkitgtk2, not webkit2gtk.
Comment by Emil (xexaxo) - Thursday, 19 January 2017, 17:54 GMT
You're absolutely right. Sincere apologies.
Comment by Erik Wesselius (erikwesselius) - Thursday, 19 January 2017, 18:27 GMT
Only after reading your comments, @Scimmia and @xexaco, I am now aware that there are three packages with confusingly similar names: webkit2gtk, webkitgtk webkitgtk2.

I am still confused about the exact nature of these parallel packages, and I agree this is not the place to find out more about that, so I will pose a question on the forums.

In any case thanks for your clarifications.

Loading...