Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#50381 - [php-mongodb] extension does not work since update of libmongoc

Attached to Project: Community Packages
Opened by Damien Carcel (Cthulhu82) - Saturday, 13 August 2016, 11:49 GMT
Last edited by Ike Devolder (BlackEagle) - Wednesday, 17 August 2016, 04:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Felix Yan (felixonmars)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Hello.
php-mongodb extension does not work anymore since the recent update of libmongoc from 1.3.5-1 to 1.4.0-1. The extension looks for the file “libmongoc-priv.so.0” provided by libmongoc, which does not exist anymore in 1.4.0-1.

Additional info:
* package version: php-mongodb 1.1.8-1
* config: no changes on original php-mongodb config; only set “memory_limit = 2G” and “date.timezone = Europe/Paris” in /etc/php/php.ini
* PHP output: “PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/mongodb.so' - libmongoc-priv.so.0: cannot open shared object file: No such file or directory in Unknown on line 0”

Steps to reproduce:
* all packages up to date
* Run “php -v” or any PHP script (composer for instance) will result with the previous output
* downgrading libmongoc to 1.3.5-1 allow the extension to work again

Regards,
Damien
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Wednesday, 17 August 2016, 04:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  rebuild with internal libmongoc for now, fixed in 1.1.8-2

Loading...