Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48808 - nvidia-340xx-utils and libglvnd conflict

Attached to Project: Community Packages
Opened by Nikolay Shirokovskiy (podosinovik) - Monday, 04 April 2016, 13:01 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 05 April 2016, 14:07 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

pacman -Syu gives me this:

error: failed to commit transaction (conflicting files)
libglvnd: /usr/lib/nvidia/libGL.so exists in filesystem
libglvnd: /usr/lib/nvidia/libGL.so.1 exists in filesystem
libglvnd: /usr/lib/nvidia/libGLESv1_CM.so exists in filesystem
libglvnd: /usr/lib/nvidia/libGLESv1_CM.so.1 exists in filesystem
libglvnd: /usr/lib/nvidia/libGLESv2.so exists in filesystem
libglvnd: /usr/lib/nvidia/libGLESv2.so.2 exists in filesystem

this files are owned by nvidia-340xx-utils (340.96-1)
libglvnd is present on on system, nvidia-340xx-utils is not listed on packages
that system update is about to bring on. So I guess the problem is
that libglvnd is not somehow marked as a substitute for nvidia-340xx-utils.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 05 April 2016, 14:07 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 04 April 2016, 15:07 GMT
Which nvidia driver are you using?
Comment by Nikolay Shirokovskiy (podosinovik) - Tuesday, 05 April 2016, 06:20 GMT
video driver is nvidia-340xx 340.96-3

BTW I disinform by mistake in bug description. libglvnd is not present on current system, it is in the list of system update packages.
Comment by Darek (blablo) - Tuesday, 05 April 2016, 09:53 GMT
libglvnd is only for nvidia 361.xx packages.
Comment by Nikolay Shirokovskiy (podosinovik) - Tuesday, 05 April 2016, 10:41 GMT
I use nvidia packages for i686 too. So pacman -Syu try to bring on new version of lib32-nvidia-utils which depends on lib32-libglvnd:

$ pacman -Si lib32-nvidia-utils
Repository : multilib
Name : lib32-nvidia-utils
Version : 361.28-4
Description : NVIDIA drivers utilities (32-bit)
Architecture : x86_64
URL : http://www.nvidia.com/
Licenses : custom
Groups : None
Provides : None
Depends On : lib32-zlib lib32-gcc-libs lib32-libglvnd nvidia-utils
Optional Deps : lib32-opencl-nvidia
Conflicts With : None
Replaces : None
Download Size : 22,36 MiB
Installed Size : 106,75 MiB
Packager : Sven-Hendrik Haase <sh@lutzhaase.com>
Build Date : Сб 13 фев 2016 15:44:35
Validated By : MD5 Sum SHA256 Sum Signature


And lib32-libglvnd depends on libglvnd

$ pacman -Si lib32-libglvnd
Repository : multilib
Name : lib32-libglvnd
Version : 0.0.0.20160315-1
Description : The GL Vendor-Neutral Dispatch library
Architecture : x86_64
URL : https://github.com/NVIDIA/libglvnd
Licenses : custom:BSD-like
Groups : None
Provides : None
Depends On : lib32-libxext libglvnd
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 150,66 KiB
Installed Size : 1404,00 KiB
Packager : Felix Yan <felixonmars@archlinux.org>
Build Date : Ср 16 мар 2016 11:06:35
Validated By : MD5 Sum SHA256 Sum Signature

This is how libglvnd is trying to pulled in.

Comment by Darek (blablo) - Tuesday, 05 April 2016, 10:55 GMT
Please install lib32-nvidia-340xx-utils/lib32-nvidia-340xx-libgl (if you use nvidia-340xx 340.96)
Comment by Nikolay Shirokovskiy (podosinovik) - Tuesday, 05 April 2016, 11:56 GMT
Thanx a lot! Sorry for posting it here. I was quite confident that it was a case of package conflicts.

Loading...