Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48069 - [linux] 4.4.1-2: Seems to detect fixed disks as a removable device

Attached to Project: Arch Linux
Opened by Martin Schnitkemper (Martin-MS) - Sunday, 07 February 2016, 11:56 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 22 February 2016, 14:26 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: After Upgrade to kernel package version 4.4.1-2 the KDE device notifier shows all partitions of fixed drives as a removable media. A extended partition of a stick was also shown as a device even if it has no mountable filesystem.

Additional info: Downgrade to kernel 4.3.3-3 or booting into the LTS-kernel solved the problem; only removable device are offered from the device notifier. Could also be an issue with KDE but since the problem happend after kernel upgrade I think its also related to the kernel.

Steps to reproduce: Update to kernel 4.4.1
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 22 February 2016, 14:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Firmware config issue
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 07 February 2016, 17:43 GMT
Additional Info: it seems to be depending of the chipset: my Desktop-Intel-H77-board (Ivy-Bridge) shows the reported issue (and also the VMs running on it) but not the Lenovo-T400-notebook with the Intel GM45 Express Chipset.
I found another report on http://unix.stackexchange.com/questions/260389/plasma-device-notifier-thinks-all-my-internal-hard-drive-partitions-are-removabl who has the same problem, unfortunately there are no more precise information of the used kernel and platform; and it was on openSUSE, so might be distribution independent.
Comment by James Crompton (DonJaime) - Monday, 08 February 2016, 18:15 GMT
I can confirm this with a moderately old XFX GeForce 9300 motherboard, but not on my notebook (Dell XPX 13, 2015 version).

cat /sys/block/sd*/removable shows 1 for both internal hard disks. So it's definitely a kernel problem.

In the absence of the faintest idea about how this part of the system works I'd guess it's probably the chipset/bus drivers rather than the disk drivers since the same bug is affecting both a Samsung SSD and a Western Digital HD on my desktop and not affecting a Samsung SSD on the laptop.
Comment by Benjamin Robin (benjarobin) - Monday, 08 February 2016, 20:24 GMT
Some information here : https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1532062
https://bugs.freedesktop.org/show_bug.cgi?id=94023
I was not able to find a bug report or a discussion about this on the kernel mailing list.
Nobody report it ?
Comment by Martin Schnitkemper (Martin-MS) - Monday, 08 February 2016, 20:59 GMT
Good to know that I am not alone... on my desktop I have a similar drive configuration as James: one Samsung SSD 840 and one WDC WD5000AAKX-6 and both devices reports removable as 1, and on my notebook I have a HITACHI HTS72501 and it reports removable as 0.
Comment by Benjamin Robin (benjarobin) - Monday, 08 February 2016, 23:07 GMT
Any chance that somebody run a bisect between v4.3.5 and v4.4.1 ?
If somebody wants to take a look, just search in the kernel source: GENHD_FL_REMOVABLE

Edit (13/03/2016): Fixed in commit https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?h=v4.4.5&id=a55479ab637cda5ebbfdb9eb7c062bd99c13d5d9
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 21 February 2016, 10:54 GMT
Latest comment #6 on https://bugs.freedesktop.org/show_bug.cgi?id=94023 did it for me: after I changed each affected device in the bios as non-hotplugable the devices are no longer shown up as a removable device.
Comment by James Crompton (DonJaime) - Sunday, 21 February 2016, 19:16 GMT
  • Field changed: Percent Complete (100% → 0%)
Not all BIOS allow setting devices as non-hotpluggable. The problem with the KDE device notifier remains even if the kernel is doing the Right Thing: there's no way to tell it to ignore disks.
Comment by Doug Newgard (Scimmia) - Sunday, 21 February 2016, 19:16 GMT
You're going to have to argue that upstream. There's really nothing that can be done here.
Comment by James Crompton (DonJaime) - Monday, 22 February 2016, 08:06 GMT
A good point. Meanwhile, a workaround:

/etc/udev/rules.d/62-internal-disk.rules
------
# don't show any partition of disk sda or sdb on the desktop
KERNEL=="sd[a-b]*",ENV{UDISKS_IGNORE}="1"
# don't show any member of lvm volume group xxx on the desktop
ENV{DM_VG_NAME}=="xxx",ENV{UDISKS_IGNORE}="1"

This will also remove the devices from the 'Places' panel in Dolphin, which in my view is no bad thing.

Loading...