Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45612 - [calibre] qt5.5 fails to find Qt platform plugin "headless".

Attached to Project: Community Packages
Opened by guido (qqqqqqqqq9) - Saturday, 11 July 2015, 16:22 GMT
Last edited by Jelle van der Waa (jelly) - Saturday, 18 July 2015, 19:28 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

ebook-convert file.epub file.mobi --mobi-file-type both --disable-font-rescaling --no-inline-toc

fails with qt-5.5 from testing. With qt-5.4 from extra everything goes well.

The error-message is:

This application failed to start because it could not find or load the Qt platform plugin "headless".
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.
Reinstalling the application may fix this problem.



Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jelle van der Waa (jelly)
Saturday, 18 July 2015, 19:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 2.32.0
Comment by Doug Newgard (Scimmia) - Saturday, 11 July 2015, 17:04 GMT
Attempting rebuild with https://github.com/kovidgoyal/calibre/commit/aa19aa903ed6f870f22f12e62eaa3a13d58f21de

I'll let you know how it goes.

Edit: Nope, problem remains.
Comment by Doug Newgard (Scimmia) - Sunday, 12 July 2015, 16:27 GMT
Got it. In addition to the above patch, you have to change QPlatformIntegrationFactoryInterface.5.2 to QPlatformIntegrationFactoryInterface.5.3 in src/calibre/headless/main.cpp

Edit: And now committed upstream: https://github.com/kovidgoyal/calibre/commit/33e085cbce88f620f1f9d30fcbf286fa80281187
Comment by Jelle van der Waa (jelly) - Friday, 17 July 2015, 09:10 GMT
With the new release (2.32.0) I can reproduce the error, so I'll have to take a closer look this weekend.
Comment by Jelle van der Waa (jelly) - Friday, 17 July 2015, 19:04 GMT
Nevermind, updated package should fix it :)
Comment by guido (qqqqqqqqq9) - Saturday, 18 July 2015, 14:14 GMT
Jepp, works for me now.

Loading...